If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

2003 Oldsmobile Alero electrical NHTSA complaints: Electrical System

NHTSA — Electrical System Problems

CarComplaints.com Seal Of This Might Hurt

2.8

hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
51,143 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2003 Oldsmobile Alero electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Oldsmobile Alero:

Unsubscribe any time. We don't sell/share your email.

2003 Oldsmobile Alero Owner Comments

problem #13

Mar 012009

Alero

  • 115,032 miles

A D V E R T I S E M E N T S

The passlock feature is defective. Numerous times I have been stranded due to my car not starting. I have gotten a new battery and the problem is still there. When the car doesn't start I will do what the manual says and turn the key to "on" and let it stay there for 10 minutes, after that it will start. That can become very frustrating when you have two small kids and it is 20 degrees outside. There really should be a recall on this feature, I took the car to the dealership and they are telling me it will cost over $400 to fix. Normal hard working people don't have that type of money just laying around to fix a car, GM really should do better. There really should be a recall to fix this problem without costing the consumer.

- Valdosta, GA, USA

problem #12

Jan 162009

Alero

  • 85,000 miles
Came out after work to start my car and turned the key and got nothing. Had the car towed before I was told it was due to the security system in this model. After researching the internet and a call to the dealer where I purchased the car I was told to leave the car in the on position for 10-15 minutes then turn it off and start the car. Which worked but at sub zero temps. This is not a very acceptable solution. And as this happens at least once a day now it is not what I paid for. The windshield has been removed and reinstalled bcs. I was told it leaked and was causing the problem and when that didn't solve it the ignition was replaced twice and to no avail it still doesn't start as it should.

- Crestline, OH, USA

problem #11

Dec 112008

Alero

  • 80,000 miles
First problem: My horn decided to go off intermittently starting at 3am, finally had to pull the fuse to stop the noise. I keep the fuse with me, but now I have no horn and it is not safe, have had a few close calls. Second problem: Turn signals fail to work at inconvenient times. Finally figured out that if I turn on my hazards for about 30 seconds then turn them off, the turn signals will work again properly. Third problem: Security light comes on, vehicle will not start. Been to the dealer numerous times for this, they finally told me to just put the key in the "on" position for about 10 minutes, and once the security light goes off the car will start. These are all safety issues that need to be addressed by GM.

- Troy, MO, USA

problem #10

Aug 092007

Alero

  • miles

A D V E R T I S E M E N T S

I have a 2003 Oldsmobile Alero that I bought used with 48,000 miles. And I have a similar problem as many other people. Sometimes when I go to put turn signal on, it won't work. This happens at random times with no notice. I often get honked at for not using my turn signal, when I have every intention of doing so, they just won't work. Also, sometimes when I start my car, the dials do not come on automatically. They all remain on zero. It has even taken up to 5 minutes for my communication system to register that I have started the car. Also, at times my air conditioner will just stop blowing. It comes back on in a few minutes, but it will come on and go off several times. Then it will finally remain on. All these things happen in conjunction with each other but I can't be able to locate the cause of the problems. I don't even know if they are related, I just know they all happen at the same time.

- Corpus Christi, TX, USA

problem #9

Oct 032008

Alero

  • 129,000 miles
Purchased vehicle August 2003 at 29,000 miles. Front left wheel bearing bad just inside warranty time - under 36,000 miles. Shortly after, front right wheel bearing went bad - not in warranty. Now at 129,000 miles, front left wheel bearing is bad again. Not using oem equipment this time as it isn't cost effective to pay for oem equipment - when it obviously lacks quality. I'm assuming my front right wheel bearing will go bad soon - better start saving for that repair! next issue - horn blows without provocation and will not stop - 3:00 in the morning. Next issue: Fuel issue, where you have to turn the key to the on position for 10 minutes then car will start. Does not happen all the time but usually when you do not have the extra 10 minutes.

- Hudsonville, MI, USA

problem #8

Jul 032008

Alero

  • 100,000 miles
I had the car since Nov 2003. I haven't had any problems until July 2008 when my car wouldn't start because of the security light flashing. I just sat there in the car until the tow truck came, so I just crank the car up and it crank I was like ok. Then another day it did the same thing and it crank up. Then the third time it did it now it wont crank up. I was wondering what do you do about this situation.

- Jacksonville, FL, USA

problem #7

Aug 012006

Alero

  • 30,000 miles

A D V E R T I S E M E N T S

Bought car in 2006, have had problems the entire time I've owned vehicle. Car does not crank, must wait 10 minutes and try to restart. Sometimes car does not start still, makes me wait another 10 min. Had multiple problems with system killing the battery while waiting - especially in winter, even with all extras (including heat) turned off. Not safe to have female in parking lot when car does not start! this happens two or three times some days, then will not reappear for a week or two, but theft light stays on dash constantly.

- Olivet, MI, USA

problem #6

Jan 082008

Alero 4-cyl

  • Automatic transmission
  • 69,833 miles
Fuel pump and electronic system.

- Grovetown , GA, USA

problem #5

Nov 162007

Alero 4-cyl

  • miles
Bought the 2003 Alero Oldsmobile in March 2007, not realizing the ongoing problems with the stalling and not starting issues. Many times with children in the car have been stranded when car would not start. First time, replaced battery; second time and third time took to mechanic spent $390 to attempt to fix car however still has issue. Mechanic said it had electrical issue with security system conflicting with wireless internet radio waves. Had to have it towed into the mechanic. Soon after a week the problem occurred again:I read on a automotive forum to put key on the "on" position for 10 minutes wait for the security light to stop blinking and then start the car (should work it stated) it worked however it is now sometimes a daily problem. I now allow 10 minutes leway in departure to allow for this aggravating problem to arise. This problem is a high security issue not safe to be stranded with single mom with kids in parking lots and as well as being out to town. Has caused to miss work. This is a ongoing issue and not sure how to remedy the problem. To add to the problem, the horn has been sounding off (as it it stuck position) for the last week 11/12/2007while driving another occurrence 11/16/07 park position key not in the ignition at 2:00am in a apartment complex. To quick resolve issue I tapped the horn on steering column it would go off again, then had roommate disarm the horn wire.

- Gainesville, FL, USA

problem #4

Nov 172006

Alero 4-cyl

  • Automatic transmission
  • miles
Car dash lights, cd player, and ac unit do not turn on when car starts. This usually occurs after the car has been driven and is warm. After leaving the car for approximately 15 minutes and then starting the car again that is when the problem usually occurs. The delay for the starting of the dash and accessories is anywhere from 5 seconds to 1 minute.

- Chesapeake, VA, USA

problem #3

Dec 212004

Alero

  • Automatic transmission
  • 15,000 miles

A D V E R T I S E M E N T S

Vehicle experienced electrical problems, such as the turn signal lights came on periodically, and the windows worked intermittently. Consumer took vehicle back to the dealer, and had also contacted the manufacturer, who was no help at all. The consumer stated that the vehicle still has electrical problems. The consumer was told that the elecrical wiring was replaced but when inspected the old wire was found still in the vehicle.

- Tucumcari, NM, USA

problem #2

Aug 282004

Alero 6-cyl

  • Automatic transmission
  • 41,000 miles
The console are next to gearshift get extremely hot when light are on.

- Kokomo, IN, USA

problem #1

Feb 112003

(reported on)

Alero

  • miles
The console area next to the gear shift had become hot when the headlights were turned on. Scc

- Galax, VA, USA

Not what you are looking for?