If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

9.7

really awful
Typical Repair Cost:
$343.00
Average Mileage:
100,779 miles
Total Complaints:
6 complaints

Most Common Solutions:

  1. not sure (5 reports)
  2. ignition switch (1 reports)
2000 Buick Regal electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2000 Buick Regal:

Unsubscribe any time. We don't sell/share your email.

2000 Buick Regal Owner Comments

problem #6

Mar 202013

Regal LS

  • Automatic transmission
  • 160,000 miles

A D V E R T I S E M E N T S

I bought a car, and the seller only gave me one key. I assumed that the key controlled the ignition and the doors, but, like I said, I assumed. I drove the car home and locked it. The next morning I was locked out of the car because it required a different key to open the door. I broke into the car and unlocked the door manually. I went to start the car and it will not start. No, it is not the battery as I have a charger/tester and jumper cables. All the lights come on and when I move the key to the start position nothing happens. I am thinking it is an issue with the VATS. Anyone have any idea as to how I should troubleshoot or resolve the problem? I read how one can check the resistance of the key and cut some wires and so on, but I am not sure I want to disable the system all together.

- , Madison, AL, USA

problem #5

Jul 072010

Regal LS 3.2L V6

  • Automatic transmission
  • 90,115 miles

My car is experiencing the problem that it stalls while driving. It has happened five times in the last month and always restarted after pulling over and placing it in park. Until last Thursday when it took 15 minutes before I could restart it. It happened again yesterday when I was taking it into the local Buick dealership for repair. I took along the other reports of the same instance from this website so they would have a starting point. I was told today that the computer check showed nothing and they were looking for a wiring problem. They have not replaced the ignition switch as in Melanie N.'s complaint. I will post the resolution when and if it is solved.Has anyone reported this to GM as it seems to occur after 70K miles.

Update from Aug 5, 2010: No repairs were made at the dealership since nothing could be found. The service advisor said to use my other key as it could be related to the chip, however the problem has recurred. Reported to NHTSA but no feedback from them at this time.

Update from Aug 11, 2011: Not resolved after spending $350 to replace the Mass Air Flow sensor.

The car still stalls while driving and I'm unaware that it has stopped until I attempt to accelerate. Since the lights do not flash until I turn off the ignition and attempt to restart it, thd situation is more dangerous than before.

I took the vehicle back to the Buick dealership, who kept it for three days and said they were unable to duplicate the problem. They said l needed to keep a computer hooked up all the time in order to access the problem when it occurs, however, they will not loan me one and I can't afford to purchase one.

Why doesn't GM acknowlege this problem?

- , Enid, OK, USA

problem #4

Oct 062009

Regal LS 3.8L

  • Automatic transmission
  • 137,000 miles

I have to get to work and doctors appts. I'm pregnant and this is a really big pain in my but. It started when I was on the highway. I put my directional on to pass a vehicle when the car started shutting the power off and on to the gas. I then took the next exit to pull off and again using my directional the car stalled out while I was going around a very sharp corner, I had no power steering. I then started my car AGAIN! and went down the road having to take another turn and turning my blinker on --- STALLED AGAIN!! couldn't get it to start back up. I waited a few minutes turned my hazards on and that's when I noticed I couldn't start the car up without the lights on the dash lighting up like its Christmas time. I finally got it home checked all the fuses and still didn't work. NOW I HAVE NO RIDE TO GO TO WORK OR APPTS.!! I don't have the money to get it fixed. So now what am I to do? OOHH and the best part is I'm still making payments til next year!!

- , Winsted, CT, USA

problem #3

Jul 192007

(reported on)

Regal LS V6 SUPERCHARGED

  • Automatic transmission
  • 71,560 miles

A D V E R T I S E M E N T S

This is an update to the problem reported a couple days ago. After taken to the dealership, they cleared all error codes that came up when they ran the diagnostic. They found a corroded battery line that they replaced, but it turns out the main problem was the ignition switch needed to be replaced. After that was replaced, the car runs and starts fine, and it has been driven to Virginia Beach and back 2 times (30 mi each way). Hope this information was helpful for all those who have the same problem!!

- , Suffolk, VA, USA

problem #2

Jul 152007

(reported on)

Regal LS V6 SUPERCHARGED

  • Automatic transmission
  • 71,000 miles

I was driving my car down the street I lived on, and I braked to turn, and my traction control lights all started blinking like there was something wrong with my traction, but my car was handling fine. The lights blinked on and off a couple more times before going off and staying off. I pulled up to my house, went inside to change clothes (I was on my way to an interview I never made because of my car), and went back out like, 10 minutes later. When I put my keys in the ignition, all the lights on my dash started blinking, and the engine would turn over, but then shut off. I tried several more times to start the car, but I was unsuccessful. When my uncle got home, he looked at it, and got it started by turning the car on and revving the engine right away. The engine shook for like a minute before settling down. When he took his foot off the gas, the engine immedialty shut off, so the car didn't idle. He tried again, and finally got it to idle, he drove it around the block to make sure we could get it down the road to a Buick dealership. We made it, and the guys at the shop told us it would be $90 just for the assessment, and they would call me on Monday (July 16th) to let me know what the problem is. So as soon as I have more information on the problem, I'll post it up here.

- , Suffolk, VA, USA

problem #1

Feb 192007

(reported on)

Regal LX 3.2L V6

  • Automatic transmission
  • 75,000 miles

will respond with price and details when fixed. all dash lights blink on start up and car will not start. when I push the parking brake down no lights flash but car will start up.

- , Mauriceville, TX, USA

Not what you are looking for?