Print this page

9.0

really awful
Typical Repair Cost:
No data
Average Mileage:
72,124 miles
Total Complaints:
4 complaints

Most Common Solutions:

  1. not sure (3 reports)
  2. Replace upper intake manifold (1 reports)
2005 Chevrolet Impala cooling system problems

cooling system problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2005 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

2005 Chevrolet Impala Owner Comments

problem #4

Nov 012016

Impala

  • Automatic transmission
  • 140,000 miles

A D V E R T I S E M E N T S

This is my daughter's car. She is 22 and drives her car a lot going between two jobs. She is losing antifreeze somewhere, but it is not leaking anywhere. We have changed the thermostat and have also purchased a new water pump, but are not sure that is the problem. We fill the antifreeze when she is ready to leave the house and in less than a 2-5 drive, the temperature on her dashboard will read in the 240-260 range. If she plays with the heater it will go up and down, but will not cool down.

- , Palos Heights, IL, USA

problem #3

Jun 132011

Impala 3.8L

  • Automatic transmission
  • 62,496 miles

THESE CARS HAVE A SERIOUS PROBLEM BEGINNING WITH THE 2001 MODEL YEAR! THE 3.8L ENGINE SHOULD BE RECALLED FOR THE UPPER INTAKE MANIFOLD, I AM A MECHANIC WHO WORKS ON A FLEET OF THESE IMPALA'S. WHEN YOU HAVE TO REPLACE UPPER INTAKE MANIFOLDS ON A REGULAR BASIS SOMETHING NEEDS TO BE ADDRESSED BY GM!!!

- , Big Spring, TX, USA

problem #2

Mar 252007

Impala LS 3.8L

  • Automatic transmission
  • 25,000 miles

this gauge problem is a pain. now never knowing if it is overheating i replaced thermostat, flushed, new hoses. did not help. Due to previously owning a 1988 chevy dualle from new it had same problem, It was the gauges as well. I had to replace entire cluster at cost of over $900.00. five years latter,same prob. looks like impala following dualle tire marks.lol, not

- , Whinchester, CA, USA

problem #1

Apr 212010

Impala 3.2L V6

  • Automatic transmission
  • 61,000 miles

This car has gotten on my last nerve!!!! It's been running hot since April 2010. I have had this car fixed several times, and I was told it needed a water pump, thermastic, and I needed to change the type of anti freeze from green to orange what the world. Just yesterday I had the car fixed again, and the guy who fixed said the belt wasn't tighten on the water pump, and this should fix your problem. Well, it did not I drove my car 3 miles and it ran HOT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

- , Dolton, IL, USA

Search CarComplaints.com for these popular complaint phrases...

Not what you are looking for?