If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

8.3

pretty bad
Typical Repair Cost:
No data
Average Mileage:
109,394 miles
Total Complaints:
7 complaints

Most Common Solutions:

  1. not sure (7 reports)
2003 Chevrolet Tahoe engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Chevrolet Tahoe:

Unsubscribe any time. We don't sell/share your email.

2003 Chevrolet Tahoe Owner Comments

problem #7

Jan 112013

Tahoe LT 5.3L

  • Automatic transmission
  • 240,000 miles

A D V E R T I S E M E N T S

Tahoe goes into limp mode when on hwy. If I pull over and take the reservoir cap off, I can drive again. Sometimes it only lasts 5 minutes, sometimes 5 weeks. The problem is also temperature sensitive, as it happens when it is cooler. During the summer, I only have this happen when the temps drop down in the 50's or lower.

- , Wentzville, MO, USA

problem #6

Jun 302009

Tahoe

  • Automatic transmission
  • 87,000 miles

I really need to fix this problem. Shutting down while driving has been really annoying and is becoming a real inconvenience. If anyone has any sort of insight on this problem please help.

- , Beaufort, SC, USA

problem #5

Oct 012010

Tahoe 5.3 Liter

  • Automatic transmission
  • 160,000 miles

I have a 2003 Tahoe that has the problem of shutting down while driving. I can be driving along and suddenly get a message on my dashboard that says, "REDUCED ENGINE POWER" and the vehicle goes to idle. I have to pull over to the side of the road, stop, and cut the vehicle off for a few seconds. This seems to help reset something on the vehicle because I can then turn the key and wait for the mileage to show up on the indicator, start the vehicle and proceed with driving. This may work for a few miles or a few days. I took my car to the local Chevrolet dealership here in Washington, NC and they told me the Throttle Body needed to be cleaned and this would fix the issue. I paid $200 to have this done( no parts involved) and 3 days later it was doing the same thing. After taking it back to them they now say the Throttle Body needs to be replaced at a total cost of $708, and they wouldn't even offer to credit the money I had already paid to have nothing accomplished the first time( it was separate work). Needless to say, I'm not going to pay them hundreds of dollars to practice guesswork on this vehicle. It seems some dealerships want to make up for lost car sales in the service departments. Well count me as one more lost sale because I won't buy a car from any place that has lost good, fair principles of doing business and offering service.

- , Washington, NC, USA

problem #4

Jun 152010

Tahoe LS

  • Automatic transmission
  • 100,000 miles

A D V E R T I S E M E N T S

Most everyone is saying that it's the ethanol in the gas that is making my Tahoe run so badly. If I'm at a red light or stop sign, the Tahoe just shakes, and studders like it is just about to go dead. It has actually gone dead, while driving! It has almost killed my 4 children and myself on 3 seperate occasions!!!! When it goes dead, it is VERY hard to steer! We have almost ran into an extremly deep ravine, and have almost been t-boned by a school bus and a freakin TRAIN!!!! Luckily, I kept my wits about me, threw it in neutral, and started it up again. And thank God, it started back up!!!

I've put the gas treatment in to try and clean the fuel injectors, and I've been buying gas with no ethanol, but it still does it every once in a while. I've noticed here lately, that it does it if I turn abruptly or stop quickly. Does anyone have any suggestions?

- , Amory, MS, USA

problem #3

Feb 012010

Tahoe ES

  • Automatic transmission
  • 115,000 miles

I would like to know if this has happened to more people or only me

- , Chino, CA, USA

problem #2

Jan 202009

Tahoe LT 5.3L V8

  • Automatic transmission
  • 41,253 miles

i want once and for ever to fix this problem what i have with this vehicle , its model year 2003 LT with just over 40,000 miles and damn , when i want to give more speed , or when i want to have more speed at the moment the vehicle shuts off, after i go with ignition key on and off which takes about 20-30 mins it starts good , just this problem its with low speed at first but now it cuts off even with low speed and if i want to drive it faster i need to increase the speed little by little not at same time , i have more but i don't want to write a book for this problem , thanks in advance any assistance would be grateful

- , Nassau, Bahamas, Bahamas

problem #1

Jul 192006

(reported on)

Tahoe 4x4

  • 22,508 miles

i want once and for ever to fix this problem what i have with this vehicle , its model year 2003 and damn , when i want to give more speed , or when i want to have more speed at there moment vehicle shuts of, after i go with ignition key in of and i back to start starts good , just this problem its with low speed , or if i want to drive it faster i need to rice speed little by little not at same time , i have more but i don't want to write a book for this problem , thanks in advance adil

- , Ferizaj, Kosovo, Serbia & Montenegro

Not what you are looking for?