If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

8.7

pretty bad
Typical Repair Cost:
No data
Average Mileage:
4,741 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (1 reports)
  2. soot clean up/cleaned egr sensors/reflashed ecm (1 reports)
  3. soot clean up\cleaned egr sensors\reflashed ecm (1 reports)
Get free help with your lemon!
close ad
2008 Dodge Ram 2500 engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Dodge Ram 2500:

Unsubscribe any time. We don't sell/share your email.

2008 Dodge Ram 2500 Owner Comments

problem #3

Mar 092009

Ram 2500 XLT 6.7L

  • Automatic transmission
  • 9,405 miles

A D V E R T I S E M E N T S

flashed the system twice. dealership acknowledges once. been in the dealership 6 times for check engine. cooling problems. charged me diagnostics each time/tow fees. never found a solution. took it to 2 other shops various times. water pump replaced, more coolant. truck emitting steam and water from tail pipe. some time later started up truck and black smoke emitted from tailpipe. towed in. diagnosed with possible bad engine. dealership wont fix under warranty says improper maintenance. by customer. In total.. in the shop over 10 times for same problems. Still no solution. sitting duck. dead paperweight @ 27,901. bank dont even want to repo it. just want to take me to court for balance due! suggestions? tuffinspections@gmail.com

- , Springville, CA, USA

problem #2

Aug 042008

Ram 2500 SLT 6.9L

  • Automatic transmission
  • 1,100 miles

Purchased the vehicle 2nd week of july 08. The 1st week of august at 500 miles the engine light came on. Dealership said it fired eng.code stating O2 sensors are bad. They replace the O2 sensor. 200 miles later the engine light came back on, Dealer states eng. code says O2 sensors bad. Replaced O2 sensors again and wrapped exhaust. 300miles later the engine lite came back on, dealer says eng. code says O2 sensors again / soot in turbo. They Replaced O2 sensors 3rd time - cleaned turbo(desooted). 280 mile later O2 sensors back on, Dealer replaced O2 wire loom, O2 sensors and egr valve. Today ...400miles later I experienced an extreme loss of power ..... the eng. light comes back on, codes are ... turbo and O2 sensors are bad. I called a Chrysler executive who claims a new turbo is on order and on the way, and that they expected my call and apologized for all of my inconvenience.

It's a Great truck, when I have it, but Chrysler has got to get their %$&T together on the repairs. I am thinking about giving the dealership my payment book since they have it more than I do.

- , Port Hueneme, CA, USA

problem #1

Nov 102008

Ram 2500 SXT 6.7L Cummins

  • Automatic transmission
  • 3,718 miles

When I drove off the lot with this Dodge Ram 2500, Cummins 6.7 4x4 QC long bed on 9/08 it was a Kick Ass ride. I had to take it back 10/31/08. for the free oil change. Not bad Love the Truck. 11/10/08 the check engine light came on. The Tech found Built Soot in system and caused the eng light on, Performed soot clean up and cleaned egr sensors and re flashed ecm, When I got it back ........It was a PINTO. Made me SICK!!! So 11/13 Im back in the shop my truck has no power. The teck found the Turbo Sticking and Failed 02 sensor.......Performed drill and tap and cleaned turbo and replaced 02 sensor. Cleaned and wrapped exhaust. I mean who does this to a brand new truck! Drill and Tap the TURBO!!! And whats up with Wrapping the Exhaust!!!! So I give it a few weeks the truck isnt the power house that it was, but it wasn't a PINTO any more. More like a family wagon. So after a short time I called DODGE 1-800 and was told I could take it to another dealership. So off I went to Chapman. 1/12/09 to the 15, my truck was at chapman, Tech found code #2262 turbo failing. Tech replaced Turbo assy and egr valve, Oxygen sensors and cleaned complete sys and performed software update on ecm and ccn. and still runs like a FAMILY WAGON!!! So after a few days I took the truck back for the oil change 1/17/09. Thought it might pick up some power. WAS I WRONG!! 1/19/09 I called Chapman and was told that the Shop Foreman would have to do a test drive. Im ok with that so I took the truck (family wagon) down. He took it for a drive and told me "with the new updated turbo and software basically i was stuck with the family wagon" "and nothing else could be done." I could trade the truck in for a 5.9 diesel or wait for the 5 years or 100k to put after market acc. to get the power i HAD!!! Then if it wasn't bad enough I have to keep going in to get nitrogen for the tires/ the TPM light.10/31/08, 12/08/08 and 12/27/08.

- , Henderson, NV, Afghanistan

Not what you are looking for?