Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
141,000 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2006 GMC Envoy brakes problems

brakes problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2006 GMC Envoy:

Unsubscribe any time. We don't sell/share your email.

2006 GMC Envoy Owner Comments

problem #2

Sep 022014


  • 160,000 miles


I was traveling over a bridge on ramp from one interstate frwy to to curve on bridge and had to abruptly put the brakes on I felt a snap in brake pedal then no brakes as I got off the curve and released brake the brakes are fine but now I get a bad shaking in front when speeds of 65 and over like the tires are wobbling.I bought the vehicle used and the first day engine blew.they say it was a rebuild I feel so ripped off.also the tire warming lights are and sometimes off.please help me.

- Chula Vista, CA, USA

problem #1

Jan 022014


  • 122,000 miles
On 12/23/13, while parked the vehicle died. When restarting, it was a little slow but did end up starting. On 12/24/13, I had the battery tested and it showed that the cca's just needed a good charge so I let the vehicle run for 45 minutes. A few hours later, the vehicle would not even turn over. On 12/25/13, removed the battery and reinstalled it. The vehicle started fine and ran well for a few days. On 1/1/14, vehicle stalled while driving. Ended up restarting but I had to give it gas to do so. On 1/2/14, I started the car to warm it up and it started fine. I let it run for 20-30 minutes before attempting to drive it. When I got in the vehicle, it said that the brake system was not working and the stabilitrack light was flashing on and off intermittently. I had to get a cab to work & have it towed to the shop. I'm hoping to hear back tomorrow in regards to what is going on. Also, had to get a rental vehicle in the meantime for transportation.

- Lincoln, NE, USA

Not what you are looking for?