Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Coolant Gauge Not Working

CarComplaints.com Seal Of This Might Hurt

5.3

fairly significant
Typical Repair Cost:
No data
Average Mileage:
89,000 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (3 reports)
2001 Oldsmobile Alero accessories - interior problems

accessories - interior problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Oldsmobile Alero:

Unsubscribe any time. We don't sell/share your email.

2001 Oldsmobile Alero Owner Comments

problem #3

Jan 012008

Alero GLS 3.4L V6

  • Automatic transmission
  • 87,000 miles

A D V E R T I S E M E N T S

The gauge has worked off and on (mostly off) since the beginning of 2008. What made it worse, the cap for the overflow tank broke when I tried to open it to check the fluid level about six months later. I could see the average temp level slowly rising over the course fo a few months, but I couldn't get the broken piece of the cap off so that I could replace it. I finally got it replaced, but I think it was the EXTREME heat of low/no fluid that led to the gasket wearing out inside the intake manifold. ..

- , Mount Vernon, NY, USA

problem #2

Nov 102008

Alero 4 Door 3.4L V6

  • Automatic transmission
  • 109,000 miles

2001 olds. alero --temp gauge went to 0 then check eng light came on with code that shows low thermostat temp--changed the temp sensor and reset the light--a few days later same thing occurred but when the computer was reset the gauge started working for a few days then came on again---this has occurred 3 times. checked the wiring bundle from the sensor to firewall and all seems good----makes me think it is the computer since it goes to normal when the computer is reset---- does anyone have any ideas?

- , Southaven, MS, USA

problem #1

Dec 132006

Alero GLS 3.4L V6

  • Automatic transmission
  • 71,000 miles

Well buying an Alero has always being a dream come true to me at first but as time went on so did the problem. I purchase this car in August 2006 and two months later the temperature gauge just out of nowhere while I am driving fell back down to the C. I am not expert but I do know that this problem is definitely not a small issue. I put a new sensor in and it started back working and then days later it did it again and again and has continue to do it. I am very annoyed by this because I want my car ( this so call dream car) to be working at a good pace. I just don't know where to turn and I don't have the money to just up and buy another car so each day I am praying for it to continue to work until I can get another one.

- , Batesville, MS, USA

Not what you are looking for?