If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

9.0

really awful
Typical Repair Cost:
No data
Average Mileage:
81,889 miles
Total Complaints:
2 complaints

Most Common Solutions:

  1. not sure (2 reports)
2001 Oldsmobile Alero engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Oldsmobile Alero:

Unsubscribe any time. We don't sell/share your email.

2001 Oldsmobile Alero Owner Comments

problem #2

May 012004

Alero 3.4L

  • Automatic transmission
  • 85,000 miles

A D V E R T I S E M E N T S

I bought my 2001 3.4L V6 Alero in 2004 with about 78,000 miles on it. For the last 5-6 years off and on my car will idle really high when I start it. This seems to happen more when it is colder or damp out and will happen every day every time I start it for 2-3 weeks and then might go 4 months without doing it. In Park, the car idles at about 3,500 RPMs and while in Drive the gauge says it is at 1,500 RPM's but it is racing like crazy and sounds like it is trying to go 60 MPH.

When this happens I will put my car in Drive and it goes by itself. I DO NOT PRESS ON THE ACCELERATOR, if it is on flat ground it takes the car about 20 seconds but it will get up to about 55mph. If I am going downhill it goes even faster. If I shut it off after driving a mile and restart it sometimes "solves" the situation and other times not.

When it first happened within 3 months of buying the car it was still under warranty and I took it in and it stopped acting up and the dealer said they could do nothing. Since then I have asked mechanics the question when taking it in for other problems, but it is never doing it when I take in and noone has had any ideas.

It is not fun sometimes to drive it and sounds a lot like problems Toyota owners are having. One of my friends sisters also had this problem with her Alero. Not sure if they tried to fix or not, but it is not good! If anyone has experienced this or found a solution please let me know. Thanks!

- , Minnetonka, MN, USA

problem #1

May 222006

(reported on)

Alero

  • 78,778 miles

I live in Arizona. Since we have been having to use the air conditioner this season, we have had a high idle problem. Upon start up (whether the air is on or not) the car idles at 2000RPM when the norm has only been about 500RPM. All during driving, the car idles high, and does not shift smoothly unless you let off the gas. We have had the tranny looked at and it is fine, the computer does not spit out codes for MAFS or IACM... SO what the problem is, we are stumped.

- , Phoenix, AZ, USA

Not what you are looking for?