Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
41,374 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2009 Chevrolet Aveo electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2009 Chevrolet Aveo:

Unsubscribe any time. We don't sell/share your email.

2009 Chevrolet Aveo Owner Comments (Page 2 of 3)

« Read the previous 20 complaints

problem #22

Feb 032014

Aveo 4-cyl

  • 33,000 miles


The low beam headlights don't work anymore. Went to mechanic, who replaced bulbs with brand new ones, and they didn't work either. They tested fuses and said those were fine. They recommended I go to a Chevy dealership to fix it but don't have the money for all that. Running around at night to get home from work on a passenger-side daytime running light only, or high beams when no one's around. Help!

- Spring City, PA, USA

problem #21

May 222014

Aveo 4-cyl

  • 89,476 miles
Drove to glen carbon short trip no sign of over heating pulled to gas station it dumped all the anti freeze out by the gauge still did not show the car was hot. [xxx] 2009 Chevrolet Aveo. Information redacted pursuant to the Freedom Of Information Act (FOIA), 5 U.S.C. 552(B)(6).

- Granite, IL, USA

problem #20

Apr 152014


  • 55,000 miles
Back in 2010, car shut off while accelerating onto freeway. Took into Chevy, could not duplicate & didn't fix. Happened 3 more times over 2 years, finally took it in 2012. Dealership shop said it was a faulty oxygen sensor in fuel line. Happened on listed date of incident in rush hour traffic, driving less than 20mph. Vehicle completely shut off. Have not taken it back to be looked at.

- Seattle, WA, USA

problem #19

Apr 302009


  • 3,000 miles


Got this car brand new off the lot with only 43 miles on it. Around 3000 miles I had my first major problem. I was going down I-95 in St. Paul, mn at around 75 miles/hr and the car jerked then cut off. Mind you this is rush hour traffic and I had 2 toddlers in the car with me. We almost got rear ended by an 18 wheeler before I could get the car to drift to shoulder. Took 3 weeks to fix the fuel pump bc the car was so new they had not made extra parts yet. About a year later I started having electrical problems- onstar not working or randomly turning on, clock resetting itself to random times, dash lights either going out or all staying on, headlights randomly working, and of course I took to 2 different Chevy dealers and neither could tell me what was wrong only that it wasn't covered under warranty =/ once the car turned 4 years on it has begun eating fuses and coil packs. This is after the coil pack and spark plugs/boots put on by Chevy after that recall. It is eating coil packs every 4-6 months and at 150-200$ a pop it is expensive especially once you factor in mechanic labor. I hate this car and wish I never got it. I miss my 96 Dodge Caravan with the oil leak and manual windows. I felt much safer in that old van and it was more reliable- it never left me even with a blown head gasket. Chevrolet should be ashamed of themselves for putting their name on a now defunct pos foreign Daewoo crap and selling it to us as american made. There isn't anything made in North America. There are a few parts made in Mexico but most are Korean made. I would never have gotten it if I had glimpsed those Daewoo stamps under the hood, trunk, and car jams.

- Burgaw, NC, USA

problem #18

Feb 112014

Aveo 4-cyl

  • 77,600 miles
Stalled at intersection. Problem diagnosed as requiring ECM programmed. Not covered under warranty dealership charged a service fee for reprogramming ECM at a cost of $250.

- West Kingston, RI, USA

problem #17

Oct 092013

Aveo 4-cyl

  • 36,000 miles
The car lost power for no reason. It did not fully stall but lost power and would not respond. It would lurch forward, barely go, then recover slightly. This happened sporadically and was frightening and dangerous. The battery light began to go off and on. Mechanics could find nothing wrong and battery ok. In November, car lost power in traffic, almost had wreck, barely made it to shop. "strangely swollen" battery found and replaced. Computer and all systems checked. Incident happened again. Back in shop. Clutch replaced, tube replaced in engine, etc. Cost $ 1500. Car seemed to run fine but only for days. Began doing same thing again. But when I take it to mechanics, can't find anything wrong because problem comes and goes. It seemed to possibly be triggered and happened more often if I used onstar built in phone. Had it turned off and thought that somehow fixed problem but it happened again yesterday in traffic with my 93 yr old mom in car. Terrifying.. can't get out of way if car coming in intersection. No one helps me find a solution. I contacted GM online they said they know of no such problem. Hundreds of posts online from Aveo owners with same problem. Someone is going to die if this isn't made public.. we need a recall. Help please!

- Decatur, GA, USA

problem #16

Jul 312013


  • 22,600 miles


After getting the front end of this car fixed(after 3 months) I was driving home when the temperature gauge stopped working. No air conditioning,90 degree day. Took the car to coastal Chevrolet in pawleys island SC where they told me it would be $300 to remove dash instruments to just get part number for gauge.then they could tell me cost of part, another $300 to remove instruments again to replace part(of unknown cost).GM once again reluctant to take responsibility for such shoddy design work, no more good will work from dealership.retired, how do I pay for a $700 temperature gauge on a car with 22,640 miles? I am so stressed, this car is a total nightmare, and I have done everything possible to keep it in good working order.there has to be an answer for customers who are caught in such a mess.

- Murrells Inlet, SC, USA

problem #15

Jul 132013

Aveo 4-cyl

  • 74,831 miles
The Aveo lt was on I-85 ramp downtown atlanta trying to build speed when it stalled at an area where there is little side access. Car cooled off and was re cranked and brought to North end of atlanta for further inspections to see if the problem could be duplicated. Car rpms were noted to vary up and down and then stalled without warning at a major intersection where it was almost T-boned on peachtree industrial blvd norcross, ga where the speed limit was 55 mph. Multiple obd codes were extracted ( a total of 6 ). car was further examined by ase mechanic shop that states that the vehicle ECM loses communication with sensors and other computers under these conditions. Ase mechanic states that ECM should be replaced. GM car dealer ( rick hendrix GMC - duluth, Georgia ) states that GM procedure is to apply sb pip4789C replacing front O2 sensor as a starting point to repair car using a newer O2 sensor that was made later than a certain date and to update ECM with newer software. GM dealer states there is no need to drive the car to duplicate problem and to review using a scanning tool as the GM procedure is to be used and will be adequate. This situation is clearly dangerous. If a simple O2 sensor could suddenly could cause a known problem of this type in accordance with the GM sb then it should be covered by the 8/80K emissions warranty. If the ECM can lose communications with other essential items and cause a problem of this type that should not only be covered under the emissions but it should also be placed on recall. As an engineer with 36 years experience I am a failure of this type. A person can be psychologically conditioned that their car is running fine and then at the next moment it completely stalls and may not allow them to clear an intersection.

- Berkeley Lake, GA, USA

problem #14

Mar 062013


  • miles
The contact owns a 2009 Chevrolet Aveo. The contact stated that he attempted to active the onstar system but it failed to connect. The contact also stated that the air bag warning lights were illuminated. The vehicle was not taken to the dealer for inspection. The vehicle was not repaired. The manufacturer was not notified. The failure mileage was unknown. The VIN was unavailable.

- Flidell, LA, USA

problem #13

Jun 302013


  • 62,000 miles
Car would not start, needle gauges flickering, inside lights on, dash lights on, but would not start or allow vehicle to move out of park. Car acted like it was locked up. Tried jumping vehicle twice but absolutely nothing. All the complaints I have read have been exactly what has happened with my car from the gas surges where I have pulled out into traffic and the car would have no power and I thought I was going to be hit, to the cruise control not working and then spontaneous coming on. We have had the car in for work at least three times for incidentals. I am fixing to trade this in from all the negative responses I have read. I am really worried about the electrical starting a fire, the car seems to have a mind of its own! never have seen needles moving on gauges when car is completely disengaged with no keys even in ignition.

- Franklin, AR, USA

problem #12

May 292009

Aveo 4-cyl

  • 1,900 miles


My step daughter bought a brand new Aveo 2009 is has been in for repairs 13 times for the same problem. It will run fine then will not go over 20mph this has happened several times while she is driving on highway at 65 mph has almost caused her and my young granddaughter to be injured. When she starts the car the clock will reset its self to 7:23 no matter what time it is that is usually the first sign it is getting ready to turn into a death trap. O2 sensor has been replaced car is again in shop they are telling her they can't find any problems but think it could be the O2 senser want $600 to replace. Her check engine light has not come on. Car is no longer under warrenty. We have contacted dealership where she bought it no help from them. Contacted Chevy asking them to admit it is a lemon and do the right thing no help from them.

- Wheatland, WY, USA

problem #11

Aug 012009


  • 200 miles
The contact owns a 2009 Chevrolet Aveo. The contact stated that after several attempts to start the vehicle it failed. The vehicle was towed to the dealer where the failure could not be replicated. The contact also stated that the failure recurred several times. The vehicle was not repaired. The manufacturer was contacted and offered to pay a portion of the repair cost. The failure mileage was approximately 200.

- Endwell, NY, USA

problem #10

Apr 062010

Aveo 4-cyl

  • miles
Went to an appointment, came back and car would not start. Had to have it jumped. A few months later went to a store, came back out car would not start had it jumped again. Had the battery checked and it showed a drain on the battery but couldn't find the cause. After having it jumped the next time the check engine light came on for a brief time then went out. Next the check engine light came on and the car immediately stopped running. Had it jumped again, it would turn over but die again. Finally had to have it towed. Took it to one shop and they couldn't find the problem. Now it is being check at another shop. Since this is the only transportation I have, I have had to cancel appointments and rely on others for over a week. This car has been nothing but a problem since I bought it and I feel that I was sold a lemon. Updated 05/02/12 the consumer was informed the computer needed to be reprogrammed. The consumer was told it was a known problem with the Chevrolet Aveo. Updated 05/04/12

- Lincoln, NE, USA

problem #9

Apr 032012

Aveo 4-cyl

  • 48,248 miles
Car would not start. Put charger on it and even tried jump starting it. Car would not even engage the starter. Engine lights would not come on and needles on the gauges would flicker up and down. Had to have dealer come and get it. They told me they had to put a charger on it for an hour before it would finally start, but did not know why cause the battery is good. Said hope it was a fluke or a module did not wake up? and to bring back if does it again. Charged a $129 for labor and tow even though have a 6 year bumper to bumper warranty. I have a feeling this will not be the last issue.

- St.Marys, OH, USA

problem #8

Apr 022012


  • miles
Dash lights went out, fuses and bulbs checked replace. Dealership says it's in need of new fuse block $700 job to fix. This is just out of warranty and I see that internal relay failing on these Chevy Aveo's are showing up on hundreds of cases like this. Need a recall to get this fixed since so many of these relays are burning up for no reason.

- Katy, TX, USA

problem #7

Apr 012011


  • 26,000 miles
My 2009 Chevrolet Aveo was bought in March with 25000 miles, in April I began having problems. After taking the car to two different Chevrolet dealerships, at separate times, the harmonic balancer was found to be worn which damaged the timing belt and had to be replaced at 28000 miles. Before this, the car was taken to the dealership for problems of not starting (occasionally). The issue could never be duplicated and was told the car was fine. Since then, the car will now act as though it does not want to take gas or that there is a "mis-fire" such as spark plugs. No lights come on. At 42500 miles when going 45 mph, the car acted as though it wasn't getting gas, or trying to "miss" and the engine light flashed three times but didn't stay on. After pulling over, turning off the car for 10 secs and restarting it, as said to do in manual, the car was able to be driven home with no security lights on. Car will once again be inspected a dealership for the same problems!!! this car should be recalled. It is not safe to drive. It "lunges" at intersections or when letting off the brake, jerks or makes a hard "miss" when traveling at a constant speed. Aveos should not be on the market. My Aveo gets great gas mileage, has no power options, which is what I wanted, but is still more trouble than any vehicles I have owned. My Aveo is driven mostly on the interstate and no more than 30 miles in each direction. It currently has 42550 miles.

- Mt Vernon, KY, USA

problem #6

Apr 012011

Aveo 4-cyl

  • 32,600 miles
I have a 2009 aveo5 purchased new in March 2009. In April 2011 at approx 32600 the vehicle stalled while I was driving, cel came on, and it would not start again for about 20 minutes. Onstar diagnostics reported "internal control module failure" P16F3. I had already requested a tow truck, and when it arrived, I tried starting it again. It started and was able to move it to get it on the tow truck. Cel was still on. Took it to mike wilson Chevrolet. They kept it 1 week, said there was no cel, no fault code, nothing wrong with it. Last night, January 2, 2012 at approx 48000 miles I experienced the same problem with the same fault code. Onstar, advance auto parts, and my own personal obd2 scanner all reported the same code: P16F3. I searched online and found tsb 09-06-04-005 (February 2009) describing the exact problem and resolution: ECM recalibration. This morning, cel is off, and I went to rod hatfield Chevrolet which was the dealer closest to me, and they said that despite having that exact problem while under warranty and having it repeated now, that they would not fix it under warranty. I feel it should have been discovered the first time in April 2011, since it was a known problem and the bulletin was published before I even bought the car. Because it was not fixed the first time, I feel it should be covered under warranty. I was in danger both times when my car stalled in the roadway. This could have been fixed the first time and I would not have been in danger last night. I am in process of filing a complaint with GM.

- Lexington, KY, USA

problem #5

Aug 012011


  • 30,000 miles
At 24000 miles the timing belt had to be replaced due to a worn harmonic balancer. Now there are more problems which cannot be duplicated at the dealership. When trying to start the car, it will sometimes not start. After waiting about 5 minutes, it will eventually start. No engine or security lights come on. As you are driving down the road, the car will "miss" and/or lunge at various speeds. It also does not want to take gas, especially at about 30-35 mph. The vehicle "pulls back" while accelerating. Unknown whether this is fuel system, engine, or transmission related.

- Mt Vernon, KY, USA

problem #4

Feb 102010


  • 15,000 miles
Vehicle lost power to the engine. Stepping on the gas pedal did nothing. The car lurched and decelerated quickly. Power was suddenly restored to engine causing the car to speed up quickly, then engine lost power again. Car came to a stop, engine sputtered and then died. No warning lights came on. Restarted engine, car drove as normal. Took to dealership, they could find nothing wrong. Problem has continued intermittently for almost a year. Have taken the car to the dealership multiple times, they can find nothing wrong. The sudden deceleration has occurred at all speeds, including on the freeway almost causing a collision. The car went from 70mph to 40mph in one minute, sputtered for a while, and then came back to drive normally after several minutes. The problem happens within the first ten minutes of driving. It has happened twice in the same day after the car sat for 8 hours. The problem has not occurred for periods as long as two weeks but then comes back. The most extreme occurrences have been on side streets where traffic was not a problem, but if another car had been following closely a rear-end collision would have been certain. My spouse has driven the car and experienced the same problem.

- Clatskanie, OR, USA

problem #3

Oct 232010

Aveo 4-cyl

  • 63,000 miles
Car looses power then surges while driving at highway speed. Car has had to has ignition coil replaced 4 times.

- Norfolk, VA, USA

Read the next 2 complaints »

Not what you are looking for?