Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
82,945 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2009 Dodge Avenger engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2009 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2009 Dodge Avenger Owner Comments

problem #5

Nov 152013


  • 105,000 miles


The contact owns a 2009 Dodge Avenger. The contact stated while driving various speeds, the vehicle suddenly lost acceleration power. The vehicle was taken to a private mechanic where it was found that the throttle body and alternator had failed. The vehicle was repaired. The failure mileage was 105,000.

- West Dennis , MA, USA

problem #4

Oct 292013

Avenger 4-cyl

  • 127,926 miles
Driving down the road and out of the blue my RPM shoots almost to the red and felt like it had the hiccups. Got to work and had the guys to put it on the computer and its giving a power up at speed code. This has been going on for long enough. Sometime the check engine comes on and sometimes it don't. when it does this it scares me and my children. Nobody is sure what the powering up at speed means and what part will fix it.

- New Albany, MS, USA

problem #3

Apr 112012

Avenger 4-cyl

  • 90,000 miles
The vehicle stalls, and the engine revs up when braking, it lists a misfire on the code reader. Not sure what this is but the internet says it may be a need for a reprogram the transmission/PCM. If it needs reprogrammed that should be a recall! this is a safety issue when braking to have the engine rev.

- Carroll, OH, USA

problem #2

Dec 082013

Avenger 4-cyl

  • 48,000 miles
The contact owns a 2009 Dodge Avenger. The contact stated that the engine failed to start the and electronic throttle control light illuminated. Additionally, the rpms would not increase over 2,000 when driving at least 55 mph. The vehicle was taken to the dealer to have a diagnostic performed but to no avail. The vehicle was not repaired. The manufacturer was made aware of the failure. The failure and current mileage was 48,000.

- Harrisville, RI, USA

problem #1

Oct 072013


  • 43,801 miles
Notice RPM / mph would rev-up...did not think much of it till I notice, having to apply brake S harder when coming to a stop becuase the car was still acceraling while I was appling pressure to brake. Notice when taking off from a complete stop or partial stop, car would stumble (RPM would drop to zero --just as to stall). Check eng. Light came on took car directly to service repair shop -code P2017(intake runner valuve error)-replace intak mainfold- (488445aj). Less then 4 hours of pick up, same problem but worst. Back to auto service center they found nothing (no codes, no errors, no warning lights). Took 2009 Avenger to a dealship-told them - driving issues I was having & no warning lights. They came back with same error "foudn cel on found intake mainifold runner value stuck), I told them I just had part replaced. They told me the part is defected, to keep my orignal warranty in place it took car back to auto service center which did the orig, job- place part 2 times (maniffold intake -kit) each time the car cont. W/ same driving issues but the last one - no codes/error after running a scan test, car was still stumbling from take off & RPM/mph rev-up when break & coming to a stop it jerks in a forward motion. Back to dealership - they stated could not find any problems. Pick up car -still same issues, car will be on its way back to a dogde dealership service dept. I feel this issue has gotten to the point of being a safey issue after serveral times not being albe to stop and car trying to stall as I try and cross major roadway. One last issue which I have notice while driving hwy mostly I notice my RPM drop and pop right back up, speed also but not as bad. All the issues appears to be something is sticking and if its the manifold -what can you do if you can only use Dodge parts - replacement(3-X's) within a 3 wks time. Plz advise Dodge to review.

- Friendswood, TX, USA

Not what you are looking for?