If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

Print this page

9.3

really awful
Typical Repair Cost:
$820.00
Average Mileage:
82,730 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (2 reports)
  2. replace battery and cables (1 reports)
Get free help with your lemon!
close ad
2007 Chevrolet Impala engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2007 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

2007 Chevrolet Impala Owner Comments

problem #3

Dec 032011

Impala LS

  • Automatic transmission
  • 45,127 miles

A D V E R T I S E M E N T S

Car would not start, jumped battery, car started. Took to auto zone to check battery. Auto Zone said all is fine. Drove home with no problem. Car sat for a couple of hours would not start again. Had to jump start car again. Went back to auto zone to check all systems. Were told systems were fine. Car kept dying. Went to dealership. Problem diagnosed as corrosion in the cables and all cables plus battery had to be changed. This is the second time the corrosion caused a problem. The first time the cables and connection were cleaned and battery changed. There was no charge because the car was still under warranty. So 2 yrs. and 4 months later the same problem occurred but this time the corrosion was all through the cables and the battery connections.

- , Sacramento, CA, USA

problem #2

Aug 102010

Impala LS 3.5L V6

  • Automatic transmission
  • 123,000 miles

I have had the same no start problem listed all over the web. Car starts fine and runs fine one minute, next fails to crank...then starts sometime in the future, from 10 minutes ..sometimes not until the next day. Just had it towed 70 miles home after a shop couldn't find the problem. I soldered the wires directlly to the key detector(the part around the tumbler that has the windings of copper wire in it) because an "engineer" on one of these sites said the terminals were tin and would corrode and cause this problem. Well the car still does the same thing starts and then fails to start some other time.

I want to take this passlock part out of the system.I just ordered the xpresskit PKUMUX module to try to install myself-have no idea if that will solve this problem. I am a big NASCAR chevy fan own Ford and Chevy..but maybe not for long. Has anyone tried the bypass module deal? Any videos on installation anywhere? This is the second time towed in the last month and the 14th time of not starting on demand. Usually it is when I want to leave work. Can someone take this to the national media...the USA is in the toilet...make this right Chevy!

- , Manteca, CA, USA

problem #1

Jul 052009

Impala LX 3.2L

  • Automatic transmission
  • 80,064 miles

THANK GOODNESS FOR GOOGLE AND THIS WEBSITE - I WAS TOLD APPROX 10 MINUTES AGO AND IMMEDIATELY I GOOGLED THE PROBLEM AND LOW AND BEHOLD - THIS IS A MAJOR PROBLEM AND I COULD BE OUT $817. NOT THIS LADY - THANKS SO MUCH FOR THIS WEBSITE - I AM SO PISSED THOUGH BECAUSE GM HAS ITS NERVE - RECEIVING HELP FROM THE TAXPAYERS BUT NOT OFFERING HELP TO ITS CUSTOMERS BY FIXING THIS MAJOR PROBLEM - I AM APPALLED AND I PLAN TO GIVE THEM BACK THEIR CAR EVEN AT MY EXPENSE - THIS REALLY REALLY PISSES ME OFF

- , Houston, TX, USA

Not what you are looking for?