Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

10.0

really awful
Crashes / Fires:
2 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
42,132 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2012 Ford Edge drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2012 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2012 Ford Edge Owner Comments (Page 1 of 2)

problem #25

Oct 172016

Edge 6-cyl

  • 50,000 miles

A D V E R T I S E M E N T S

Issue - 'shift to park' warning indicator is shown when the vehicle is parked and the shifter is in the 'P' position. Doors cannot be locked and internal/external lights remain on while in this 'shift to park' position draining the battery. While foot brake pedal is engaged, shifting away from 'P' and back to 'P' sometimes registers the vehicle as in the correct park position. Repeat until warning message is gone. The vehicle is stationary on a flat surface but I am not sure if the vehicle is really parked since it's warning I'm not but the shifter is in the 'P' position. I dare not try this on a hill--and always the brake pedal engaged while I'm fiddling with the hand shifter. When did this happen? at least 4 times a week for a year.

- La Puente, CA, USA

problem #24

Jun 242016

Edge

  • 95,000 miles
6/24/16 took car to dealer for check engine light. Repair $329. Indicated purge valve stuck open at times. 6/30/16 check engine light again. Indicated under boost....replaced waste gate vacuum sensor. $307. Returned to dealer again for check engine light due to hose clamp loose. Began experiencing door ajar light and interior lights that don't turn off. Returned to dealer on 8/15/16 and were told the turbo assembly needs to be replaced for $2500+. could lose power and cause further engine damage if driven. Tried contacting Ford via email with no response. There are clearly safety issues and recall should be issued and repairs at Ford expense. Tired of reading of these same Ford issues but selective state and model repair.

- Huntley, IL, USA

problem #23

Apr 112016

Edge

  • miles
The contact owns a 2012 Ford Edge. The contact stated that the vehicle stalled without warning four months ago. The contact's husband replaced the half shaft, but the failure recurred. The vehicle was coasted to the side of the road and was unable to restart. The contact was unsure whether the VIN was included in NHTSA campaign number: 14V393000 (power train). The contact was to check with the manufacturer for more disclosure concerning the recall. The vehicle was towed to the contact's residence. The failure mileage was not available.

- Mount Gilead, OH, USA

problem #22

Apr 152016

Edge

  • 65,000 miles

A D V E R T I S E M E N T S

I purchased my low mileage Edge from local Ford dealer. Experiencing periodic issue with car transmission lag or jerking when accelerating from stop, as at a stop sign or pulling out of parking lots. Took to dealer several times, they can't duplicate issue, no codes. More recently the backup camera has intermittently failed. No backup guidelines are present, sometimes backup camera is visible, then goes black, other times doesn't work at all. Now my brakes are giving me issues. The pedal will either be very hard to press, as in losing power braking when a vehicle dies. Then the pedal may go all the way to the floor. Did experience something similar while in fast food drive thru, foot on brake, then brake losing pressure and pedal depressing to floor. I put the vehicle in park, then the "service advance track: Light came on briefly. This vehicle is not safe and once I make a list of all of the service bulletins it's going to the dealer for repair. Last time I went the idiot at the service counter put that I said the vehicle "stalled". never did I say that happened. I said there was a lag in acceleration and the feeling like a transmission jerking into gear. Piece of junk Ford, don't know what I was thinking buying it. All of these complaints on this site, amazing there aren't more accidents. Shame on you Ford! you used to make quality products.

- Cleveland, TN, USA

problem #21

Apr 042016

Edge

  • 68,000 miles
The contact owns a 2012 Ford Edge. While placing the vehicle in park and exiting the vehicle, it rolled downhill across the street and struck a tree. The contact stated that the vehicle would not register that it was in park. The vehicle had to be restarted numerous times in order for the vehicle to register that it was in park. The vehicle was unoccupied at the time of the failure and the air bags failed to deploy. A police report was not filed. The vehicle was towed to an independent mechanic where it was awaiting repairs. The manufacturer was made aware of the failure. The failure mileage was 68,000.

- Manchester, MD, USA

problem #20

Feb 172016

Edge

  • 93,000 miles
While driving, the vehicle stopped pulling. The motor was still running and started vibrating. Turned off the car and then restarted it. It felt like the car was in neutral. I have seen the recall on the halfshaft disengagement and am not sure if my car has had this recall fixed. This has happened twice in the last 10 days.

- Armuchee, GA, USA

problem #19

Jan 212016

Edge

  • 43,000 miles

A D V E R T I S E M E N T S

Three times in two week experienced sudden loss of power all in motion. Third time I was on the freeway ramp. Coasted/limped to hard shoulder. As twice before the wrench icon appeared on panel along with '"AWD off". turned off engine, waited a minute, and restarted engine. Everything now fine and got home. Took to Ford dealer. (Ford of escondido) they cannot replicate the problem. Told everything checked out ok. Could find no error reports under diagnostics. Told to pick up car. Left car at dealer! this sudden loss of power is a huge safety concern. If I had experienced this on the freeway instead of the ramp, I could have rear ended at 65mph!

- San Diego, CA, USA

problem #18

Jun 102014

Edge

  • 34,000 miles
Traction control activates for no reason ( dry weather). Resulting in total loss of power at express way speeds. It will deactivate ar some point but recycles several times.. once car is parked and turned off clears it self.. fo D can not find out why this happens.

- Ellijay, GA, USA

problem #17

Jul 152015

Edge

  • 38,500 miles
Sometimes when I put the car into park, I get repeated warnings to "shift to park". if I don't jiggle the button on the shift knob, my seat and other electrical components will not respond. I have to start the truck a few times, put it through the gears (in drive and reverse), then I press the shift release button several times then the warning stops and my driver seat functions to allow me to get out of the car. This is a pain and the dealer said that if the problem couldn't be duplicated, then they cant do anything about it. I have had the truck in 2 times about this - the transmission shifts hard into gear after slowing or coasting and then accelerating. Almost feels like I have hit something when it happens. I'm very concerned, having two toddlers in the truck. I also took video of the parking, shifting into park issue. I just want it fixed....

- O'fallon, MO, USA

problem #16

Dec 152014

Edge 4-cyl

  • 45,600 miles
As I pulled into the parking deck at my office (going less than 10 mph), I suddenly had little ability to steer, nothing happened when I pressed the gas and the "low oil" light came on. I was able to coast to a stop and just barely steer clear of nearby vehicles. Restarted the car and was able to back into a parking spot. Drove it to the dealer where they spent the entire day trying to replicate the issue to no avail. I had noticed what I would describe as vibrations in the steering wheel prior to the incident (it's an approximately 25 minute drive from my house to the office in stop/go traffic with the last several miles on a busy interstate with my office just off the exit) but at the time I chalked it up to the construction on the highway and varying levels of asphalt. From my personal research online, most people who have this issue continue to have it at both low and high rates of speed and those who have had a remedy were only able to do so if the dealer could get their hands on the vehicle to read the code immediately before the car was restarted. It seems that the error code is disappearing when the car is restarted which could explain why the dealer could find no code on my vehicle.

- Charlotte, NC, USA

problem #15

Nov 112014

Edge 6-cyl

  • 69,000 miles

A D V E R T I S E M E N T S

The battery was going dead when vehicle left off and parked overnight. The gear shift is not communicating that the vehicle is in park and the displays would come on and drain the battery overnight. The error was mis-diagnosed and a new battery was purchased. The issues continued and the dealership states it is the gear shifter wiring. This should be a recall item, there is nothing to be done in normal daily use that could have prevented this.

- Aurora, CO, USA

problem #14

Sep 102014

Edge

  • 40,000 miles
Throttle body failure.

- Parkland, FL, USA

problem #13

Sep 052014

Edge 6-cyl

  • 44,000 miles
While driving at 45mph, vehicle lost power to the extent that I had to pull over on the shoulder. A mechanic wrench light appeared on the dash. Vehicle remained running but idle was very erratic. After ignition was turned off, I used a code reader and dtc "P2111" appeared on the reader (throttle body failure). After clearing the code, I restarted the vehicle and engine idle appeared normal. Drove vehicle for 20 miles with no other abnormalities. During a brief review of Ford recalls, tsb's, etc. I am finding that there are known issues with the throttle body on other models but for some reason not the Edge.

- Wichita, KS, USA

problem #12

Aug 292014

Edge

  • 43,500 miles
While driving down the highway my vehicle suddenly flashed a message that said "AWD manual turned off." I could not accelerate, nor could I brake. I was lucky that the cars behind me did not rear-end me. I was forced to coast off the side of the road and wait for the car to stop on its own. Had I not had access to a shoulder on the road I would have been stranded in the middle of the highway. My mechanic stated they are replacing the throttle body.

- Hillsborough, NC, USA

problem #11

Aug 102014

Edge 6-cyl

  • 48,562 miles
This has recurred 3 times in the last 3 weeks. The last time it happened, I was backing out of my driveway and the car started jerking, wouldn't accelerate and the wrench light came on. I turned the vehicle off, waited a couple of seconds, restarted it and it worked great. The time before I was going about 55 mph and the car did the same thing. I pulled over to the side of the road, turned it off and restarted and it worked great. I'm afraid to travel in the vehicle. The Ford dealership said it's the electronic throttle body and will cost $400+/- to fix.

- Thomasvillee, GA, USA

problem #10

Aug 082014

Edge 4-cyl

  • 58,400 miles
Alarm and dash icon warn driver to shift into park. I pull off the road and shift into park with no problem apparent in the shift or transmission. This alarm is recurrent mostly when moving on the roadway and occasionally when car is still. This problem according to the Ford dealer is a defective switch in the shifter lever assembly. This is a $325 repair and too complex to complete myself. This issue is distracting to safe driving requiring finding the ok button or pulling off the roadway to shift the lever.

- Nicholasville, KY, USA

problem #9

Jul 112014

Edge 8-cyl

  • 34,000 miles
I was unable to come to a complete stop and hit a cone in nyc. After, it was extremely difficult to come to a complete stop. The car was able to slow down but it took time. I drove slow and away from others. The brakes were hard and made noise when I pushed down on the brakes. When I went to the dealer, they informed me that Ford has an extended warranty on the part and I asked why wasn't the part recalled if it put me and my family in harms way. Why wasn't I notified prior to losing full braking power" I am thankful that I noticed the problem right away and my family and I are safe. I have concerns for others who may be at a greater speed when the brakes fail or have to stop unexpectedly. In addition, my car has returned to the dealership for service several times for not locking into the park position. It is not safe and again, I have concerns for my family and others. Can this car move if it isn't secured in the park position" I have voiced my concerns with Ford but have been given the run around by everyone I have encountered. These are safety issues and no one seems to care. Everyone is nice and apologizes but they need to take care of these safety concerns for their customers and for the general public.

- Bethpage, NY, USA

problem #8

Jun 172013

Edge 6-cyl

  • 30,000 miles
On multiple occasions while driving between the speeds of 25mph and 80mph on european roads/highways the car loses ability to accelerate regardless of pressure on gas pedal. I had to pull over, luckily avoiding cars and possible collisions. Car displayed yellow wrench and "AWD off" on left side display. Once in safe area I turned off the car, waited for a few minutes and turned it back on without immediate incident. This happened a total of 7 times within a week, however, after contacting Ford service stateside I was told to go to an italian Ford dealership. However, I stopped at two Ford service centers located in vicenza, italy and the mechanics will not touch my car due to the model not being sold anywhere in europe. The problem stopped up until this past week where it has happened again twice within 3 days at, luckily, low speeds and avoiding all cars/hazards. We will attempt to bring it to a local mechanic in hopes of getting the problem fixed as we are leaving for the states in less than a month due to military pcs orders.

- Apo, AE, USA

problem #7

Jun 242014

Edge

  • 24,230 miles
In stop and go traffic at low speeds, the vehicle has stalled multiple times (11 times in the last year and a half). The most recent time in heavy, slow-moving construction traffic. Car loses all power without warning. Loss of power steering, very tight brakes, no acceleration possible and a low oil warning. I have to turn the car off and restart, this sometimes works, other times I have needed the car towed because it did not restart. This is a company car and it has been to the dealership multiple times, and only this last week was anything ever found to be wrong. All previous times the stalling could not be duplicated, and I was told either nothing was wrong with the car, they fixed a part they thought might be the problem, or I must have put in bad gas. After stalling a month ago, this past week a data recorder was attached and a defective oxygen sensor was found in the emissions system when the car stalled for the dealership. The oxygen sensor was replaced and they test drove the car. The stalling did not occur during their final test drives. I received the car back a week ago, only to have it stall three times within 10 miles two days ago. Almost was re-ended by a semi-trailer truck this last time as I was in the middle of six lanes of traffic, and with no steering, was helpless to move. Have stalled out in a gas station, rounding corners in intersections, at stop signs, driving down my street, and now four times on the highway during low speed traffic congestion. Having the car towed to the dealership as I am too afraid to drive it. There are at least four other complaints about this issue on the NHTSA website, and it sounds like very similar to symptoms seen in the GM recalls. Car stalls without warning in more and more dangerous situations. This issue needs to be addressed by the manufacturer because of its dangerously serious nature.

- Waukegan, IL, USA

problem #6

Jan 032014

Edge

  • 41,000 miles
On multiple occasions starting in the beginning of the year my car started stalling and would just cut off in the middle of the street. It happened many times after that so I took it to my local Firestone because my car was out of warranty. They suggested it may be bad gas and they did a throttle body flush. So between the flush and using mid grade gas from a different station it worked for about 1,000 miles then the problem started again. My car would shake and rev and on many times cut off in the middle of an intersection, thank god it never caused an accident especially with my 2yr old daughter being with me most of the time. I took it to Ford dealer and after the $100 diagnostic they told me the throttle body was defective and Ford had recalled many throttle bodies recently just not for my car yet and the throttle body is not part of the drive train so it's not covered. So I had to pay $600 that I really didn't have to get this issue corrected after paying over $500 late last year to fix the brake booster on a 2012 vehicle. I have had so many problems with this vehicle and this new throttle body issue is the last straw. I will never buy another Ford product again.

- Palm Beach Gardens , FL, USA

Read the next 5 complaints »

Not what you are looking for?