Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
0 / 0
Injuries / Deaths:
1 / 0
Average Mileage:
13,136 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2015 Ford Edge drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2015 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2015 Ford Edge Owner Comments (Page 1 of 2)

problem #27

Oct 082016


  • 8,000 miles


Engine goes to idle while underway, orange wrench appears on panel, no response from throttle. Happens without warning at any time, high or low speed. Extremely dangerous. I cannot imagine why there has been no recall on this.

- Oldsmar, FL, USA

problem #26

Sep 012016


  • 6,200 miles
At 6200 miles on a clear warm day of about 95 degrees, at about 40mph on a flat city road, the car lost all power of acceleration, and I had to pull over and come to a complete stop. The engine light and a wrench light appeared on the dash display, and hill start assist unavailable message appeared. I put car into park and shut off engine, waited about 2 minutes, and restarted engine. The engine idled roughly and the accelerator pedal produced no results when pushed. Shut engine off again and waited about 5 minutes and restarted. Accelerator pedal worked normally, and drove off. Wrench light went out and engine light went out after about 20 miles. No accidents were caused as there was enough time to react and travel was on a local street while going straight.

- Fresno, CA, USA

problem #25

Aug 172016


  • 439 miles
My car is Ford Edge 2015 with only 439 miles on it. I was turning right when attempted to accelerate the car just shut off by itself. I managed to drift into a parking lot to stop the car.. no check engine light was on just a message displayed on the dash "full accessory power active" and the green light on the starter button was flashing. Had to put the car in park and wait 2-3 min until I could successfully restart it. Request research help

- Roanoke, VA, USA

problem #24

Aug 142016


  • 83,082 miles


The contact owns a 2015 Ford Edge. While driving approximately 50 mph, the vehicle lost power without warning. The vehicle was coasted to the side of the road, turned off, and restarted; however, the failure recurred. The vehicle was towed to a local dealer, but the failure was unable to be duplicated. The manufacturer was made aware of the failure and promised to investigate the issue. The failure was not diagnosed nor remedied. The failure mileage was 83,082.

- Rusby, MD, USA

problem #23

Aug 122016


  • 9,660 miles
While driving vehicle, it shudders and the engine shuts off. The car lights stay on in the interior and exterior - but the information screen goes black and then the back up camera turns on. Car will not accelerate -- stays like this for a few moments then goes back to normal but then happens again -- usually 3 times within 3 minutes. This is the second time my vehicle will be going into the service dept. The first time I was driving on a major highway going 75mph, speed dropped to 60mph within a matter of seconds - would not accelerate and rear view camera was on. Second time, at a stop light and the car shuddered and turned off when driving through the green light the engine shut off again. Then, as the vehicle was being pulled off the road and out of traffic the engine shut off again. Vehicle was towed to service dept. Ford says there is nothing that can be found.

- North Ridgeville, OH, USA

problem #22

Aug 052016


  • 7,048 miles
I Ford Edge has a bumping sound on the passagner side. It was a brand new vechile. But it made this noise. Come to find out after it broke down the throttle body and power train. I was told by the dealer that their was a recall by fcc said their was no recall. Fcc would not buy the car back. The dealership did "fix" it but what really is a fix ( a patch) which means it will break down again. The car would not crank or make any noises! it just stopped in a parking spot.

- Wedowee, AL, USA

problem #21

Aug 052016


  • 12,200 miles


Fwd 3.5 V6, 7 month old car with 12,200 miles- driving on interstate when engine just quit with no warning. Wrench symbol illuminated on dash. After shutting down, car was able to be restarted, only to have the same problem after 3-5 minutes. Car was towed to Ford dealer, where problem was diagnosed as a faulty throttle body. Dealer said they see a lot of this problem and that I was fortunate that they had the part in stock. I felt I was fortunate to be able to safely pull the car over, without causing an accident. Car was repaired the next morning.

- Canton, GA, USA

problem #20

Jul 262016


  • 11,760 miles
On 26 July 2016, I encountered a sudden and inexplicable problem with my vehicle that involved the loss of the ability to accelerate... while I was in traffic on a busy road. The gear shift was still in the żdriveż position when the incident occurred requiring me to drift into a driveway/parking lot, narrowly averting an accident. I was in the process of attempting to pass another vehicle. Needless to say when this incident happened I found myself, and my grandchildren, in a very dangerous situation. As the moment the vehicle is unsafe to operate. On 27 July the same issue reoccurred three more times (all on local streets), once while I was in an intersection, while I was on my way to the cowles Ford dealership to have the vehicle serviced. The service manager, took my vehicle in (he graciously provided a loaner vehicle) and one of the service representatives, hypothesized that the problem might be related to the throttle. IżM not sure if the issue was mechanical or related to the computer system. The service manager indicated that it may take about a week to service the vehicle due to the volume of service requests, so I will not know if the vehicle is drivable until after the first week of August.

- Manassas, VA, USA

problem #19

Jul 282016


  • 6,700 miles
I was driving on a busy highway at about 45 mph and I couldn't accelerate. Luckily I was able to coast off to the side burn. My car only has 6700 miles on it. They towed it to the dealership and the dealership told me that they can't get it into to look at until August 1st. The apparently won't even give you a loaner car in the meantime. Very frustrating. This could have been a very dangerous situation.

- Purcellville, VA, USA

problem #18

Jul 272016


  • 5,100 miles
The contact owns a 2015 Ford Edge. While driving approximately 55 mph, the vehicle decelerated to 15 mph when the power train wrench warning signal illuminated. The contact coasted the vehicle over to the side of the road, turned off, and restarted the vehicle. The vehicle was driven back to the contact's residence. The vehicle was not diagnosed or repaired. The manufacturer was not made aware of the failure. The approximate failure mileage was 5,100.

- Sugarland, TX, USA

problem #17

Jul 102016


  • 14,500 miles


Driving with cruise on at 55 to 60, yellow wrench comes on after feeling the car shutter, cruise stops working but was able to keep it up to speed. Kept driving, at every stop light the car acts like it wants to stall but doesn't, then acts like it is in 3rd or 4th gear when taking off. Shut the car off and re-started and it acted fine. Then, the next day, the same thing happened when my wife was driving on her way to work in stop and go traffic. This yellow wrench came on about 10 months ago and it cleared when shutting the car off. Dealer said to keep an eye on it and it may have been a glitch. Spent a ton of money on this car and we don't even feel safe driving it! getting the throttle body replaced as we speak so hopefully that will fix it for good. Less than 15,000 miles on the car.

- Freeland, MI, USA

problem #16

Jul 022016


  • 12,000 miles
While driving home in my 2015 Ford Edge titanium, I turned into a side street and pressed the accelerator to continue driving. Car shut down completely. I could not advance. After sitting for a few minutes, everything came back on. I was able to restart the vehicle and made it home. A car that puts my life in danger like this could also put other lives at risk. This is a very dangerous situation and needs to be addressed.

- Eawsley, SC, USA

problem #15

Jul 012015


  • 15,330 miles
The vehicle drivetrain warning light went on. We were driving about 45 mph on a hilly two lane road. The vehicle lost all power. Luckily we not being followed closely as we had no ability to get any power after the warning light came on.

- Deal Island, MD, USA

problem #14

Jun 252016


  • 11,088 miles
Etb electronic throttle body failed while driving putting me in danger on the road and causing my car to go limp. I was driving 70 mph in a 75 and lost power and control of the vehicle. It was all I could do to put the car on the shoulder without an accident. The wrench light came on the dashboard. It was towed to texarkana and I am in rockwall tx waiting on 15000 of these parts are on back order with Ford to come in for my car. This is hopeless. It's dangerous to have this car stall like that and to know 1.6 million have already.

- Rockwall, TX, USA

problem #13

May 262016


  • 10,000 miles
Throttle body. Ford Edge titanium new car - have for roughly 6 months - 10,000 mileage driving on highway doing 65 - 70 miles an hour. Car makes a beep noise and a large wrench appears in the left screen on the dashboard. No ability to use gas pedal which is now locked up - cannot press down. Car is slowing down. Only options to go to side of road and turn off. Car can be restarted. Take to dealership asap (happens again on the way - this time only driving approximately 30 miles an hour). Dealership says it is the throttle body and they have ordered part to repair. Been without a car for a week. Still awaiting for dealership to repair.

- Tinton Falls, NJ, USA

problem #12

May 162016


  • 29,359 miles
5th stall 5/16/2016 turned left onto the I-90 on ramp, hit the gas and at ~40 mph the car shuddered and went into limp home mode. Pulled safely to the shoulder and ran the vehicle health report. The report shows issues with hill assist and safety restraints. (29,359)

- Sammamish, WA, USA

problem #11

Mar 292016


  • 6,000 miles
Vehicle stalled again. First time October 2015 (filed a complaint). I was traveling on a road at relatively low speed and vehicle just stalled. Restarted quickly, a vehicle should not just stall for no reason, especially a new vehicle.

- Camarillo, CA, USA

problem #10

Oct 212015


  • 600 miles
In a parking garage, turning right at slow speed and vehicle stalled. No warning, all was going smooth until vehicle just stalled. Vehicle restarted. Informed dealer. Dealer service department "reprogramed PCM per tsb 15-0123". thought all was taken care of until stalled again in March. So reporting now.

- Camarillo, CA, USA

problem #9

May 082016


  • 4,863 miles
Car lost power at 60 mph was able to coast to side of road and restart. Same day on interstate going 70 mph same thing but had very little room to pull off. Restarted and once again coming to stop light on rt. 61 was able to coast to side and restart. All this happened within 1to2 hrs. This was on Sunday 5/8/16 mileage on car 4,863. Mon. 5/9/16 took car to sands Ford of pottsville and was told that they could not determine what went wrong and cleared the engine light and to drive car and see if it occurs again. Ford Motor Co. Will not replace anything until they know what causes it to shut down.

- Pottsville, PA, USA

problem #8

Apr 132016


  • Automatic transmission
  • 4,500 miles
The contact owns a 2015 Ford Edge. While driving approximately 60 mph, the vehicle lost steering and braking ability, but the vehicle was still idling. All the warning indicators illuminated. The contact coasted the vehicle to a parking lot and had it towed. It was diagnosed that the transmission failed and needed replacement. The vehicle was repaired under warranty. The approximate failure mileage was 4,500. Updated 05/31/2016

- Skowhegan, ME, USA

Read the next 7 complaints »

Not what you are looking for?