Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


fairly significant
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
12,006 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2015 Ford Edge electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2015 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2015 Ford Edge Owner Comments

problem #18

Jul 292016


  • 10,000 miles


The contact owns a 2015 Ford Edge. The contact stated that the vehicle experienced a loss of power. The check manual and engine warning indicators illuminated. The vehicle was taken to the dealer where it was diagnosed that a ground cable was loose and needed to be replaced. The vehicle was repaired; however, the vehicle experienced a loss of power. The vehicle was towed to the dealer where it was diagnosed that the throttle was defective and needed to be replaced. The vehicle was repaired. The manufacturer was notified of the failure. The failure mileage was 10,000.

- Kirkwood, MO, USA

problem #17

Jul 012016


  • 12,000 miles
Driving down major highway. Car engine lurched and then suddenly lost all acceleration power. Had to coast to a stop by side of highway. Engine continued running very roughly. No acceleration or ability to drive. Dealership deemed it a electronic throttle body failure.

- Culpeper, VA, USA

problem #16

Jun 242015


  • 5,700 miles
While on highway car went from 45 mph to under 5mph without warning. Lost all functions steering acceleration and braking. Wrench appeared on dashboard see manual. Luckily a car was not behind could have been a serious accident. Went to Ford said could not find an issue

- Brooklyn, NY, USA

problem #15

Jun 262016


  • 7,800 miles


After stopping at a stop light, in attempting to pull out, the car engine stopped... there was no power. I was able to coast and pull over then restart the engine. This immediately happened again and roadside assistance was called. This was very very dangerous as I had no power in the middle of a busy intersection! this turned out to be the throttle body motor which was defective!

- Export, PA, USA

problem #14

Jun 062016


  • 4,750 miles
The contact owns a 2015 Ford Edge. The contact placed the chip from the starter button in his pocket. When the chip was slightly bumped, it opened the trunk of the vehicle. As a result, the trunk became damaged. The vehicle was taken to a body shop and the mechanic stated that the frame of the vehicle needed to be replaced. The dealer did not diagnose the failure. The vehicle was not repaired. The manufacturer was aware of the failure. The approximate failure mileage was 4,750.

- De Pere, WI, USA

problem #13

May 162016


  • 29,359 miles
5th stall 5/16/2016 turned left onto the I-90 on ramp, hit the gas and at ~40 mph the car shuddered and went into limp home mode. Pulled safely to the shoulder and ran the vehicle health report. The report shows issues with hill assist and safety restraints. (29,359)

- Sammamish, WA, USA

problem #12

Apr 222016


  • 5,222 miles


My car lost acceleration at 65 mph on the highway. Indicator lights illuminated and after pulling over and turning the car off was able to accelerate again. Was able to pull over to the side of the highway with no acceleration. I was in the slow lane, this could have been a potentially life threating situation if I would have been in a different lane with faster moving traffic. After the car was turned off and then on again, was able to accelerate. Drove about 5 miles to take the vehicle to the dealership and lost acceleration completely again. Purchased new in December 2015, currently has 5222 miles. This is the second issue with the car. The first issue was with the back passenger door. It was not aligned properly and sounded like air was coming in. Had to have door realigned.

- San Bernardino, CA, USA

problem #11

Mar 152016


  • 27,500 miles
3/15/2016 within 24 hours of picking the car up from the second reflash of the PCM and being told that the oil level was causing the stalling the Edge died on the I90 on ramp at eastgate. Bad news. Not even 24 hours after picking the Edge up it died while merging into I90 at eastgate. I have now owned this car just over 60 days and driven a total 1,900 miles during which it has gone into limp home mode 4 times. Evergreen has reprogrammed the PCM twice. This last time it was in I was told the oil level was too high and caused the motor to shut down. Well the oil level was set to the factory specification by the tech and yet it shut off again today. (27,462.6) finally the tech at the dealer was able to replicate the stalling last Friday but 5 days later my car is still at the dealer waiting for Ford to tell them what if anything they are authorized to replace

- Sammamish, WA, USA

problem #10

Feb 062016


  • 26,500 miles
The contact owns a 2015 Ford Edge. While driving 30 mph, the vehicle stalled without warning and all the warning lights on the instrument panel illuminated. The failure recurred several times. After the third time, the vehicle was taken to a dealer where it could not be diagnosed. The dealer received a bulletin about the vehicle and reprogrammed the PCM; however, the failure recurred. The manufacturer was not made aware of the failure. The failure mileage was approximately 26,500. Updated 05/04/16

- Sammamish, WA, USA

problem #9

Mar 022016


  • 27,250 miles
2/26/2016 left Edge at Ford dealer who reprogramed the PCM 3/2/2016 turning from inglewood road onto 228th accelerated going up the hill, car jumped from ~30 to 40 then shut down into limp home mode, service light flashing, pulled to the side ran vehicle health report, turned off and restarted the car.

- Sammamish, WA, USA

problem #8

Feb 182016


  • 26,800 miles


While passing (going from 40-60mph) a slow car in the right lane of highway 405 hit the gas pedal and the car shuddered and went into limp home mode, had to pull right across two lanes ran vehicle health report, turned car off and restarted

- Sammamish, WA, USA

problem #7

Feb 062016


  • 26,500 miles
Turning off of sahalee way on to highway 202 hit gas pedal and car lunged and then end into limp home mode, had to pull off the road turn the car off and restart

- Sammamish, WA, USA

problem #6

Jan 042016


  • 3,041 miles
On January 4, 2016 the vehicle entered a safe mode in the middle of traffic. Without notice, while in motion and in the middle of traffic, the vehicle shut down; deployed the emergency brakes; and attempted to dial 911. It nearly caused an accident in the middle of a busy intersection. We promptly took the vehicle to the dealership, where they said the issue could not be replicated. The regional representative at Ford customer service stated that if the issue could not be replicated Ford would not be able to do anything else. The vehicle is brand new, with around 3000 miles. We are concerned about the vehicle and Ford's unwillingness to address the issue.

- Indian Land, SC, USA

problem #5

Oct 222015


  • 1,000 miles
I have accidentally shut off my car while driving mistaking start button for radio button. This was my fault, but this is not a safe feature for any driver. Fortunately this time I was sitting at a traffic light and was able to restart the car.

- Saline, MI, USA

problem #4

Sep 162015


  • 765 miles
I was stopped at a stoplight in clear, warm weather when the engine silently turned itself off. Not realizing this, I attempted to turn, but the Edge was off. Ac and radio remained on. I did not see any warning lights on the dashboard. After a few frantic minutes, I noticed the small green light on the ignition button was flashing. I put car in park and was able to restart engine. We have only driven the car a few times since and no problem. I fear this happening while driving in traffic. Vehicle had 765 miles on it- we had it for 3 weeks.

- Fitchburg, WI, USA

problem #3

Sep 272015


  • 1,221 miles
We had stopped at a red light and then we proceeded through the light and the transmission shifted hard from 1st to 2nd gear (auto transmission) but didn't think anything about it. We then turned into a parking lot at tampa international airport and the vehicle's engine just shut down before we came to a stop. We coasted into a parking space and the automobile was unresponsive to me trying to shut everything down for approximately 3 to 5 seconds. There was a notification that appeared on the dash when the engine shut down but I don't remember what it said. It then allowed me to depress the start/stop button that allowed the electrical system to shut down for a re-start. I then restarted the engine and picked up my passenger and drove home. The vehicle has been problem free before the incident and did not cause any problems on our return drive home. We were very lucky to have been in a parking lot and not on a busy highway pulling in front of oncoming traffic.

- Bradenton, FL, USA

problem #2

Sep 212015


  • 683 miles
Drove Edge all day with no problems, then for no reason, the display in dash went blank. No warning lights came on. Could not tell speed, radio would not work, steering was sluggish, vehicle drove rough, front windows would not operate, but rear windows worked. Luck I was 1 mile from dealer; managed to limp to dealer where I contacted my salesman. He drove around parking lot and had same problems.left Edge at dealer. Next day called service dept. And advised them of same issues and was told they have never had anything like that in for repair. Have only had vehicle 30 days, bought new, only 680 miles.

- South Prince George, VA, USA

problem #1

Apr 242015


  • 14 miles
I was able to drive my brand new 2015 Edge with the battery light on and was told that it may be a faulty light that would turn off. Couple of weeks later light was still on. I took the car to my nearest dealer and was told my alternator had to be replaced and that I should not drive the car further. I was out of a car for 1 week because parts were not available.

- Montebello, CA, USA

Not what you are looking for?