Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: Say what you will about the styling of the Ford Edge, but the bottom line is owners seem to love this vehicle. That is, of course, except in the case of it's dangerous, worrisome and unexplained issues with random engine stalling.

Our data suggests an early defect trend, as owners of the 2007-2008 models have started posting their accounts of what happens when you're driving down the road and the engine just stops. Some at high speed, some at low speed but always a random shutdown of the engine, electrical and power steering.

Time will tell if this becomes a widespread issue, but there's no drying the seriousness of the problem. With that in mind, we're flagging the Edge with our "Beware of the Clunker" rating until the situation improves.


really awful
Crashes / Fires:
2 / 2
Injuries / Deaths:
1 / 0
Average Mileage:
78,107 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2008 Ford Edge electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2008 Ford Edge Owner Comments (Page 3 of 5)

« Read the previous 20 complaints

problem #60

Sep 262014

Edge 6-cyl

  • 52,741 miles


Took my vehicle in early for service at sunrise because was concerned about loud screeching noise on brakes and erratic behavior of vehicle -surging. When driving. When the service tech (troy) opened the hood he asked em to get out of the vehicle and stand back, as the top of the battery was spattered with black oil looking material and apparently he and another technician were concerned it might rupture or explode. They asked em to get out of the vehicle, give them the keys and that they would check the vehicle and asked me to wait. About 90 minutes later they came out and said all was fine, nothing wrong with battery or brakes. I left and drove vehicle home and same problems were occurring, I returned and after calling and saying same things were occurring. I had hped to speak to [xxx], who was an amazing service supervisor, but he was not there and another man who was rude claimed the battery was still under warranty but that it was normal to have oily sludge on the battery. He said it was "normal, because it was just sweating". he refused to do anything..said the brakes needed to be at 3 before Ford would replace them. I asked that he contact Ford corporate and inquire. He said, "no he would not" the battery I should add since I have owned the vehicle has been repeatedly replaced. I have limited driving the vehicle, except for short local trips, and tonight the vehicle would not start and aaa claimed the battery was defective and clearly dead. It is most disturbing when Ford misrepresents their warranty and refused to acknowledge defects that have been published in their won alerts. Seriously dangerous! there are numerous postings of other Ford Edge owners having these problems. Please investigate their questionable protocols on dangers that are known with their vehicles. Information redacted pursuant to the Freedom Of Information Act (FOIA), 5 U.S.C. 552(B)(6).

- Van Nuys, CA, USA

problem #59

Dec 192014

Edge 6-cyl

  • miles
The driver door ajar warning is illuminated on the dash and the doom lights wont turn off. I have found out this is a very common issue with Ford where the poorly designed door latch binds up. I had this same issue with my 2002 Explorer and now with my 2008 Edge. It becomes a huge safety issue at night since the dome lights will not turn off so it is hard to see outside and could potentially cause an accident. From what I can tell I have been lucky to get this far before this issue has surfaced since I have read that Ford cars 2 to 3 years old seem to have this very same issue.

- Shoreview, MN, USA

problem #58

Dec 272014


  • 83,277 miles
My husband was driving with me and our 2 children on the highway at 70 mph. All gauges (fuel, speedometer, odometer, etc.) stopped working and the odometer read "odo data error". we had a gps that we were using and displayed our speed, so we kept going the 5 miles to our planned stop along the way home. When we restarted the car, the gauges were back up but it made a loud thumping sound when changing gears. It reversed fine (but we were on a slope), then thumped again as we switched to drive. The car only revved and did not move. We reversed again to situate ourselves so the slope was in our favor when we switched to drive. It was a tough start, but it did go. I called the dealership to report (this was on a Saturday) and was told that I could bring it in, but they wouldn't be able to look at it until Tuesday. We made it home (another hour drive), but I'm not using the car again until I drive it to the dealership. The car is not accelerating properly.

- Coppell, TX, USA

problem #57

Nov 292014

Edge 6-cyl

  • 71,000 miles


I was driving down the highway when my speedometer and odometer stopped working. Then it told me I had a error and a fault in my tire pressure system. My airbag light came on, indicating that it was off. I pulled over and turned off the vehicle. When I started it back up all the error messages cleared, but when I went to put my car into drive it sounded as if the transmission had dropped. I tried driving only to rev the engine up to 3000 RPM with barely any movement. When ever shifting from drive or reverse it made that loud popping noise. I took it to a dealership to be told it stopped doing it but they didn't fix it. They made no repairs. They are letting me pick the car up and drive it again with out any actual resolution, but they did charge me money to "look at the car". do people actually have to die for someone to issue a recall? I am reading thousands of reviews about the Edge that experiences the same problems. Lets issue a recall and develop some accountability!

- Ypsilanti, MI, USA

problem #56

Oct 162014

Edge 6-cyl

  • 106,500 miles
When driving all of a sudden the truck speedometer goes blank, the odometer drops to zero and the wrench, airbag and eventually the tire pressure lights illuminate. When pressing the accelerator the car struggles to accelerate because it starts losing power. I then have to pull off the road, turn the car off and allow the car to reset itself. I turn the car on, the lights are out but when I try to accelerate there is still little power so I have to press the accelerator to the floor an then the power kicks in and the car operates normal. This is a safety hazard because it has happened to me 4-5 times, on the highway. This is a safe hazard because it can potentially cause a tragic accident.

- Upper Marlboro, MD, USA

problem #55

Nov 102014


  • 40,000 miles
The vehicle says "driver door ajar" at random times when the door isn't actually open (from doing nothing more than opening and closing the door, rolling down the window, locking the doors, etc.). while this may seem more like a hassle than a safety issue, it is too an issue of safety. When the vehicle is in "door ajar" mode the dome lights come on. This is dangerous when driving at night. When the vehicle is in "door ajar" mode, the car will not lock. People need to be able to lock their vehicle for safety reasons that I probably don't need to spell out. I've read a few Ford forums, with numerous people discussing this same issue. Why hasn't their been a recall to address this?

- Not Providing, MN, USA

problem #54

Jun 012014


  • 54,000 miles


Rear bulbs failure changed 4 times since 6/01/2014 last change 10/24/2014 both sockets black and burned haven't changed sockets.

- Chicago, IL, USA

problem #53

Nov 142012

Edge 6-cyl

  • miles
Door ajar icon on all doors closed dome lights only go off when car is in motion however if you hit brakes as if your going to stop dome lights come back on.

- Fairburn , GA, USA

problem #52

Sep 242014

Edge 6-cyl

  • 127,000 miles
I pulled out of my driveway and everything was fine. I pulled out of my neighborhood and as soon as I gave it any good amount of gas it starting driving really rough and shaking and the A/C went out you could hear the misfire on the cylinders and the transmission was revving high before it would shift gears. No check engine lights or anything at this point. I turned back around and took my car back home turned it off and then turned it back on and that's when the check engine light came on. We pulled the code and it was P0352 (ignition coil 2 or PCM) so we bought and changed all spark plugs and coil 2. this still didn't fix the problem. So I took it in to the dealership and $3000 later they had to replace my PCM (the main computer that run the car) all 6 coils and spark plugs. I did a lot of research about my car having this problem and it seems like a lot of people are having the same issue. Please recall this. My computer should not have gone out when I do regular maintenance on my car.

- Arlington, TX, USA

problem #51

Sep 202014

Edge 6-cyl

  • 125,980 miles
I was driving under normal conditions at about 35 mph when the transmission seemed to be slipping and the wrench came on the dash and the car lost all power. I came to a stop and shut the car off and checked the transmission fluid and it was good. I started the car again and it would rev high but barely move. I got home slowly and parked it and when I came back out later and tried it, all the power was back and the wrench was gone and it didn't clunk into gears like it was earlier. I think by shutting it off and taking out the key for a couple hours reset a computer glitch in this car. I have heard many stories just like mine and speaking for many 08 Edge owners we want this recalled. This could result in tons of mechanic bills and unanswered issues for owners.

- Suamico, WI, USA

problem #50

Sep 112014


  • 125,000 miles


Hello, my 2008 Ford Edge is having a lot of transmission fricking issues !!!! shifting hard into reverse and from 1st to 2nd !!!

- Fairview , OR, USA

problem #49

Aug 302014


  • 100,000 miles
This has now happened to me twice with both my small children in the car while on the highway, at highway speeds. T he speedometer went to 0, the maintenance wrench display lit up, along with the error message "tire pressure monitor fault" (or something to that effect) and I was unable after stopping at a stop light to accelerate almost causing the person behind me to rear end me. Once getting to my home when putting the car into park it makes a loud clunking noise then proceeds to jerk the entire vehicle. After letting the car sit for an hour I tried to turn it one once again and test driving a few feet forward, it only moved at a slow pace when gas pedal applied.

- Mesquite, TX, USA

problem #48

Jul 212014


  • 60,000 miles
Left rear turn/tail light is continually not working. I replace the bulb, thinking that would correct the issue but as it turned the bulb melted into the socket which had to be replaced. I've replaced the socket/connector 2X and now it's looks like replacement #3 is inevitable. I researched the internet for similar complaints and found several postings of the same problem. Can anyone tell me if there is a recall on this issue? if not, there should be one!

- Urbandale, IA, USA

problem #47

Aug 242014


  • 96,000 miles
Loss of power to the extent of next to no acceleration, transmission not shifting smoothly or correctly, odometer blanks out with dashes, speedometer quits working, airbag light and transmission wrench illuminate in the gauge cluster.

- Yuma, AZ, USA

problem #46

Feb 012014

Edge 6-cyl

  • 84,000 miles
When I put into gear the transmission jerks into gear. All the vehicle codes go off at once. One incident I lost power when I came to a stop at an intersection. I accelerated and vehicle hesitated to accelerate. The. Speedometer read zero and I was clearly going over 40mph. I have only had the vehicle 7mos. I took it in for service at the Ford dealer twice and was told it was nothing and that it might be the battery. Today is the final straw. I am writing this at the Ford dealer. The transmission is jerking way to much. It is unsafe to drive. And they are trying to put me in a new car..I want my car fixed..

- San Bernardino , CA, USA

problem #45

Aug 212014

Edge 6-cyl

  • 92,000 miles
Driving home with 2 babies under the age of 3 in my car the airbag and wrench light flashed and odometer had dashes. Car began to lose power I could not accelerate. Turned the car off went to put it into reverse and the whole car jumped. I have had problems before with the car jerking when going low speeds. This is so bad. Can not put the car in reverse without a loud clunk.

- Waxahachie, TX, USA

problem #44

Aug 192014

Edge 6-cyl

  • 49,563 miles
While driving down van born road (heavy traffic) the speedometer stopped and went to 0 mph, the odometer read dashes, the wrench illuminated in the corner, and the airbag warning sign appeared. The RPM's in my vehicle began to climb higher as well and the car speedometer did not indicate any mph and began to decrease, after slowing down at ta red light I noticed my car would barely move and it slowly crept until I got home 1/2 mile from when I noticed the problem start. As soon as I parked other warning lights began flashing such as the tire pressure sign. I turned the car off and then back on and I experienced a hard start, which was loud, and when I went to change gears the car jerked violently as if the motor was jumping. When placing in reverse gear the jerk was even more violent, loud noise as if the engine was dropping out or I was being rear ended. I turned the car off and back on to see if the warning signals were still illuminated and they reset. When trying to see if the car would move I had to push the gas pedal almost all the way to the floor before the car would even move a little bit and again the RPM's revved really high. I ended up calling a tow truck this morning 8/20/14 and they stated that the transmission is trying to skip first gear and go directly to second gear; my car is currently in the shop. Prior to this incident I experienced occasional jerking while driving and the car was switching gears. It was very scary being a female and not knowing much about mechanics. Only 49,000 miles.

- Dearborn Heights, MI, USA

problem #43

Aug 172014


  • 64,000 miles
The contact owns a 2008 Ford Edge. While driving approximately 60 mph, the service engine and seat belt sensors suddenly illuminated. A message displayed on the instrument panel indicating "data error". the contact also mentioned that the speedometer stopped operating during the failure. The vehicle operated normally once the engine was turned off and restarted; however, the failures soon recurred. The dealer stated that multiple sensors were faulty. The vehicle was not repaired. The failure mileage was 64,000.

- Philadelphia, PA, USA

problem #42

Aug 182014

Edge 6-cyl

  • 146,825 miles
Gauges on dash stop working. Tool symbol shows up also tire pressure warning and exclamation mark. Carstarts to slow down. When car is put in reverse it makes a loud clucking noise. Like the motor is gonna fall out. Can't drive it forward but U can go in reverse. This has happened several times. If you let the car sit for a few days it goes back to normal. This has to be a serious problem because lots of people on youtube have posted videos of the same problem! now I'm stuck over 100 miles away from home. Not cool Ford!!!!!

- Vacherie, LA, USA

problem #41

Jul 052014

Edge 6-cyl

  • 113,000 miles
Three days after passing my annual Texas state inspection while driving through town I initiated my left turn signal only to have the indicator blink very quickly (not the normal tick-tick-tick blink). This had happened a couple of years ago so I knew one of the bulbs had burned out on the left side. I went to the local auto parts store, purchased replacement tail light bulbs & bulb grease and asked if they could change it out for me. Upon removing the covers, the young man discovered a fried/melted assembly. There is no way to remove the bulb it is so melted in the socket and the socket is discolored from the heat. That must have been some power surge to do that kind of damage.

- Sulphur Springs, TX, USA

Read the next 20 complaints »

Not what you are looking for?