2013 Ram 1500 electrical problems: various electrical issues

Various Electrical Issues

2013 Ram 1500

This problem may be covered under warranty. Ask your Ram dealer.

7.5

pretty bad
Typical Repair Cost:
No data
Average Mileage:
11,900 miles
Total Complaints:
17 complaints

Most Common Solutions:

  1. not sure (14 reports)
  2. clock spring to be replaced (1 reports)
  3. reset the computer (1 reports)
  4. wiring is not insulated properly (1 reports)
2013 Ram 1500 electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2013 Ram 1500:

Unsubscribe any time. We don't sell/share your email.

2013 Ram 1500 Owner Comments

problem #17

Apr 162013

1500 Big Horn 5.7L

  • Automatic transmission
  • 3,500 miles

A D V E R T I S E M E N T S

Dash Lights, radio and headlights turn off for approximately 5 seconds and then come back on. As of 10/22/2017 they have yet to figure out whats wrong. Almost a year ago the check engine light came on and they cant get it to go away. Even put a new computer in my truck and the check engine light is still on. I'm very disappointed with the fact I still have these problems after 4 1/2 years.Truck should have been bought back as they cant figure out whats wrong. That would have been the right thing to do. I have read about a 100 complaints from various web sites about this same or very close to same problem. And when it happens at 75 MPH on the freeway at night its scary as HELL. Buying this truck back is going to be a lot cheaper than the lawsuit my family will bring if I die in an accident.

- Steven B., Walker, US

problem #16

Apr 012014

1500 Express 3.6L V6

  • Automatic transmission
  • 35,000 miles

I would put my truck through a local " touchless" car wash and within minutes the gauges, dash lights, horn, headlights, shifter would all start going nuts, flashing on and off. Sometimes the truck would stall while driving. The problem always went away before the dealer service department could get a look. No code in the computer to guide them, either. After taking it in 3 times for a total of 12 days, I finally convinced the service manager to take it to my car wash (after they took it to one near them and nothing happened). Halfway back to the dealer all the craziness happened to him. In the meantime, I researched online and found someone in Ohio reporting a similar problem. It turned out that wiring passing through the firewall was improperly insulated and would short out on the metal. I guess the water from the car wash was hitting the area just enough increase conduction. As soon as it dried out it went back to normal.

The service department patched it up and I have not had the problem since. This was 4 years and 120k miles ago. Yes, I said 120,000.

- Tom O., Danbury, US

problem #15

May 032016

1500 Bighorn 5.7L

  • Automatic transmission
  • 46,000 miles

battery light comes on . battery gauge pegs out, lose all power. no power steering windows a/c nothing.

- Matt P., Comer, GA, US

problem #14

Sep 132016

1500 Longhorn 5.7L

  • Automatic transmission
  • 21,150 miles

A D V E R T I S E M E N T S

In the AM after starting, all the buttons on the left side of steering wheel and behind the spokes were inoperable. The horn was inop. Buttons on the right side for shift and speed control worked. I took is to the nearest dealer since I wasn't sure it was safe. Dealer kept it for a day and did some work then returned it to me next day as OK. IT WAS NOT FIXED. Tech earlier mentioned that it was probably CLOCK SPRING failure. This at 22,100+ miles? Because this happened at 36 months, 3 weeks after purchase, may not be covered! I called Chrysler and complained. I am now waiting to hear if Chrysler will pay to replace clock spring. Dealer service was pretty poor. This is my first Ram, previously 15 year F-150 with minor problems.

- Allen F., Hayden, ID, US

problem #13

Oct 132015

1500

  • Automatic transmission
  • 36,000 miles

As you're driving down the road all of a sudden the damn Dodge ghost appears and everything of the dash, all lights, radio everything starts flashing, just going completely APESHIT!!!!

- Johnny M., Kilmichael, MS, US

problem #12

Aug 142013

1500 Laramie Longhorn 5.7L Hemi

  • Automatic transmission
  • 8,949 miles

Went for FOUR months without a dealer trip!!! Then the same thing all over again -- GPS freezing. Radio / Satellite etc not working properly

* this is the second of 13 *

- remzy, Rogers, AR, US

problem #11

Apr 112013

1500 Laramie Longhorn 5.7L Hemi

  • Automatic transmission
  • 512 miles

A D V E R T I S E M E N T S

GPS would not load correctly

RADIO would change channels if I hit a bump just right

* this was the FIRST of 13 (THIRTEEN) trips to local dealer with electronic problems *

- remzy, Rogers, AR, US

problem #10

May 142013

1500 Longhorn Hemi

  • Automatic transmission
  • 5,000 miles

The screen on my center console and the dashboard electronics just go out while driving. Never has been able to fix for the two years I have owned the truck. Usually it will reboot and come back on. This is scary while driving. Twice it has stayed out for hours. This prevents and changes to air-conditioning, heater, defroster, radio... Dealers do "software" upgrades but it never address the issue. This occurs 3-4 times a week. First and Last Dodge I will ever own. Now a TIPM has gone out that blows fuses and prevents backing up of the boat trailer. My bumper to bumper lifetime extended warranty at $2800 is not going to cover this and Ram is stewing me for $1200 more. Stay away from this manufacturer!

- Greg S., Moring View, KY, US

problem #9

Dec 022013

1500 Laramie Longhorn 5.7L Hemi

  • Automatic transmission
  • 15,158 miles

Another FOUR months until I see the smiling dealer AGAIN, same electrical problems RADIO / GPS, (added a 15,000 mile maintenance on this trip)

* This is the 4th of 13 trips for the same thing *

- remzy, Rogers, AR, US

problem #8

Aug 222013

1500 Laramie Longhorn 5.7L Hemi

  • Automatic transmission
  • 9,170 miles

ONE WEEK out of shop and repeating the same crap with electrical GPS / RADIO.

* This is the 3rd of 13 *

- remzy, Rogers, AR, US

problem #7

Nov 252014

1500 SLT 5.7L

  • Automatic transmission
  • 15,000 miles

A D V E R T I S E M E N T S

2013 Ram 1500: the radio has bad reception andlot of static, also the odometer keep going out and I don't know why? The acc plug on dash keep going out. This is a new truck, I don't really understand why?

If any one else has this going on let me know. I keep going to dealer..

Thanks

connspider

- connspider, Waterbury, CT, US

problem #6

Dec 262013

1500 Hemi

  • Automatic transmission
  • 1,036 miles

I purchased this truck, new -- and all was well the FIRST SIX MONTHS. After that, the lift suspension quit working on the key fob and lights kept coming on inside the truck saying the battery was low. I took it to the dealer and to make a long story short, it was in there around 30 days, 4 separate occasions, not fixed and more and more warning lights were showing up.

The truck DIED on me overnight because lights would come on at different times when nobody was even in the truck. It's like it had gremlins and was possessed. A month later it had to be towed because the battery went dead a second time. Chrysler, Colorado Springs Dodge -- nobody knew what was going on.

To top things off -- I was sold some bogus extended warranty and did nothing while these problems kept occurring!!! I got porked with a loss there of $2800, not including their lies and all the grief.

I sold the truck because the dealership was not working ethically with me and the problems just kept compiling.

- brat1111, Colorado Springs, CO, US

problem #5

Jan 222013

1500 Express 5.7L

  • Automatic transmission
  • 6 miles

Try to program power off to 0 sec via 45 sec. Will not stay, reverts back to default setting of 45 sec. 5 min or 10 min option in programming will not stay either.

- poole3, Suffolk, VA, US

problem #4

Jul 122013

1500 Big Horn 5.7L

  • Automatic transmission
  • 2,200 miles

The electric folding mirrors do not work now, It seems the electrical system in this truck is haunted! It also seems like many other people are having the same problems with electrical systems. That is something that they will never get fixed. It seems to be one thing right after another.

- jrange, Owasso, OK, US

problem #3

Jul 082013

1500 RT

  • Automatic transmission
  • 3,100 miles

We bought a brand new 2013 RT Dode Ram on May 2, 2013. It has been in the dealership 3 times. For unknown reason when you get on the road the dashboard lights all turn on like a Christmas tree. The service engine turn on, the service airbag, the traction control, the speedometer goes all the way down to 0, it won't indicate the speed you are going, the steering wheel becomes hard to turn, and last but not least the truck turns off. I was stranded 7 hours away from where I leave just this Monday 7/8/13 and I had to get it towed to the dealership I bought it 7 hours away and we are Thursday 7/18/13 with no diagnostic problem. According to the dealership service manager a chrysler team was called to review the vehicles since they can't find the problem. I'm wanting answers and I don't get none. It's ridiculous to have bought a new truck and to have it in the dealership more than what we have actually used it. I will upload the video on youtube soon so that you may view what is going on.

- Nora G., Brownsville, TX, US

problem #2

Dec 222012

1500 Laramie V8 Hemi

  • Automatic transmission
  • 155 miles

After getting our tire fixed we experienced a code saying "memory system unavailable please put in park" it would happen every minute. Then the radio would skip from gps to aux to radio to satellite every 2 seconds.the Eco mode stopped working creating high rpms and hard shifting. The key fob would not work and the auto start as well. The truck ran horribly.

- Brian K., Brantford, Ontario, canada

problem #1

Mar 222013

1500 Laramie 5.7L

  • Automatic transmission
  • 21 miles

service electronic brake system warning light, cruse control not working. still in shop waiting on parts, not off to a good start. this is my 5th dodge truck

- fergy57, Lewisville, TX, US

Not what you are looking for?