Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: Say what you will about the styling of the Ford Edge, but the bottom line is owners seem to love this vehicle. That is, of course, except in the case of it's dangerous, worrisome and unexplained issues with random engine stalling.

Our data suggests an early defect trend, as owners of the 2007-2008 models have started posting their accounts of what happens when you're driving down the road and the engine just stops. Some at high speed, some at low speed but always a random shutdown of the engine, electrical and power steering.

Time will tell if this becomes a widespread issue, but there's no drying the seriousness of the problem. With that in mind, we're flagging the Edge with our "Beware of the Clunker" rating until the situation improves.


really awful
Crashes / Fires:
2 / 2
Injuries / Deaths:
0 / 0
Average Mileage:
75,867 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2008 Ford Edge drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2008 Ford Edge Owner Comments (Page 4 of 9)

« Read the previous 20 complaints

problem #115

Mar 122015

Edge 6-cyl

  • 65,500 miles


Was driving on freeway about to exit and transmission sounded as if it got stuck on 2nd gear. Engine sounded loud at high rpms and my speed dropped. I got the vehicle towed to my well trusted mechanic and he concluded that my transmission needs to be replace. Vehicle only has 65,500 miles.

- San Diego, CA, USA

problem #114

Feb 082015


  • 108,000 miles
The transmission (automatic) will not go out of the first gears. There was a loud thud noise and then the car wouldn't shift, I had to put it in neutral and then back into drive to get it to work several times.

- North Chesterfield, VA, USA

problem #113

Jan 202014

Edge 6-cyl

  • 83,680 miles
I bought a certified pre owned 2008 Edge in June 2013. I first experienced the hard jerking probably early 2014 or maybe in the winter of 2013. It had trouble shifting up when came to a complete stop. This happened several times and I took the car to the dealership but they couldn't reproduce it. They fixed a transmission leak and updated some software on two separate visits. Both times the problem went away for a few days and then came back again. It was not serious enough then. This year it occurs more often (usually in the stop and go traffic) and there is also abrupt jerk when the car shifts up from 10-20 mph or from 20-30 mph. The powertrain malfunction symbol came on today. But after I let the car sit for half an hour and restarted it, the symbol was gone. I'm taking it to the dealership soon and hope they can do something. The problem seems to only occur in cold weather. There are many people complaining about this issue online. It could be dangerous if it happens at an intersection or on a highway. Ford should recall these cars because they are unsafe to drive.

- Waterville, ME, USA

problem #112

Jan 172015


  • 99,300 miles


I just been told by koons that I would have to pay 1,300 to fix a throttle issue on my 2008 Ford Edge, which I purchased as a used vehicle labor day special 2014. The car stalls, stops, acceleration is affected. Ford knows the throttles are faulty and instead of recalling, they did a customer satisfaction and agreed to repair affected Edge from 2009-2014. This is bogus I have 2008, which that has this issue. I refuse to pay this and don't have the money to invest in junk. Koons told me because of my hesitation I was investigating in a car that has valued equity & would offer great trade. They knew..they yet put me in another dangerous car. I had accident as well, driving ca lost speed & stalled while crossing over in parking lot.

- Fairfax, VA, USA

problem #111

Jan 142015

Edge 6-cyl

  • 85,000 miles
This has happened twice in the last two weeks. Once at 45 mph, once at 60 mph. Speedometer goes to zero despite maintaining speed. Display shows od data error. Airbag, tire pressure, and wrench lights come on. Pull over, turn off engine. Restart. Reset button. Transmission feels like it is in a higher gear, shifts hard little acceleration power.. once you get it to shift up to a high gear seems to shift/drive normal.

- Clearwater, FL, USA

problem #110

Jan 212015


  • 85,000 miles
Traveling at highway speed, dashboard lights up with check engine light, airbag light, get odometer failure, speedometer stops working, followed by a tire pressure sensor failure. Transmission stops shifting properly including a loss of power especially when resuming from a stop.

- East Bridgewater, MA, USA

problem #109

Dec 272014


  • 83,277 miles


My husband was driving with me and our 2 children on the highway at 70 mph. All gauges (fuel, speedometer, odometer, etc.) stopped working and the odometer read "odo data error". we had a gps that we were using and displayed our speed, so we kept going the 5 miles to our planned stop along the way home. When we restarted the car, the gauges were back up but it made a loud thumping sound when changing gears. It reversed fine (but we were on a slope), then thumped again as we switched to drive. The car only revved and did not move. We reversed again to situate ourselves so the slope was in our favor when we switched to drive. It was a tough start, but it did go. I called the dealership to report (this was on a Saturday) and was told that I could bring it in, but they wouldn't be able to look at it until Tuesday. We made it home (another hour drive), but I'm not using the car again until I drive it to the dealership. The car is not accelerating properly.

- Coppell, TX, USA

problem #108

Dec 132014


  • 82,000 miles
Driving along the freeway, when all of a sudden I noticed the dimming of lights in my car, and then the speedometer and engine odometer (revs) all dropped to 0, along with the wrench signal coming on, along with the airbag signal coming on, and then eventually the tire pressure signal coming on. The car lost acceleration and I was able to get off the freeway at the next exit. I tried to put my foot on the accelerator, I could hear the engine revving but the car only moving at 10 miles an hour, wouldn't go any faster, although I could hear it, it wouldn't click over, or accept the change in gear.

- Reseda, CA, USA

problem #107

Nov 292014

Edge 6-cyl

  • 71,000 miles
I was driving down the highway when my speedometer and odometer stopped working. Then it told me I had a error and a fault in my tire pressure system. My airbag light came on, indicating that it was off. I pulled over and turned off the vehicle. When I started it back up all the error messages cleared, but when I went to put my car into drive it sounded as if the transmission had dropped. I tried driving only to rev the engine up to 3000 RPM with barely any movement. When ever shifting from drive or reverse it made that loud popping noise. I took it to a dealership to be told it stopped doing it but they didn't fix it. They made no repairs. They are letting me pick the car up and drive it again with out any actual resolution, but they did charge me money to "look at the car". do people actually have to die for someone to issue a recall? I am reading thousands of reviews about the Edge that experiences the same problems. Lets issue a recall and develop some accountability!

- Ypsilanti, MI, USA

problem #106

Dec 012014

Edge 6-cyl

  • 58,800 miles
While at a stop sign on a small sloped road, my vehicle rolled backwards when I let go of the brake to accelerate from a stopped position. There were children walking behind me and I almost rolled into them. In addition, while parked in a forward position on a small sloped driveway, I was unable to drive out of the driveway without applying my foot to the brake and the gas at the same time. I almost hit the car in front of me. I brought it to the Ford dealership and was told this is how the Ford Edge is designed and this is normal. Essentially, I need to hit the brake and gas when on a slight slope. This is very disturbing and dangerous.

- Milford, CT, USA

problem #105

Nov 222014


  • 130,000 miles


While preparing to stop at a light, seemed to have lost all power. Speedometer dropped to zero, airbag light came on and odometer was blank with a readout in its place that said something like odo failure also the wrench icon lit up. Shifted to park and the car jumped and jerked and loud grinding noises came from transmission. Was able to creep to a side street. Turned off engine. Waited several minutes, restarted car and the instrument panel returned to normal. Drove home about 3 miles. Took it to shop and they said it was a shaft seal. They replaced it for $182 the part was $12. Got home and it leaks very badly it has leaked about a cup of fluid in 4 hours.(this was parked / not running) I am taking it back to the shop and hoping they can fix it right. I have been driving for over 30 years and never had this kind of problem.

- Evansville, IN, USA

problem #104

Nov 122013


  • 68,000 miles
When driving at low speeds and the transmission shifts from 1st to 2nd gear there is a very hard jerk when the shift is made. Also have had issues with the transmission going into a fail safe mode which puts it into 5th gear when you are trying to take off and the acceleration is very slow. Could lead to an accident while trying to cross traffic and you expect to be able to take off in first gear and have proper acceleration.

- Owosso, MI, USA

problem #103

May 022014


  • 115,000 miles
In may, I was traveling at 55 miles an hours, when my car lurched forward and all the dashboard lights came on. The speedometer stopped showing my speed, the RPM's maxed out, lost all low gears, and the accelerator was not responding properly. I went and had the transmission looked at and the oil changed, engine flushed, etc. Several weeks later I had the same problem. After a short time the car started responding properly again. On 11/14/2014, I was traveling at 60 mph and experienced the same thing for the 3rd time. Once I got to a safe location I pulled over. When I put the car in park it made a terrible noise. I called roadside assistance to tow the car to the dealership. The dealership has said it is the transmission but have yet to determine the exact problem. I do not feel the power train of this vehicle is safe! other problems that have occurred since owning the vehicle: Lunging at red lights when brakes are engaged (sometimes feels like I have been rear ended), electrical running to rear lights is melted, excessive amount of corrosion on the battery cables, rear wheels/brakes growling causing excessive wear on brakes (brakes went out coming to a stop sign one day), radiator fan problems, failure of the coolant fan 2 times and was replaced, tubing for windshield spray eroded.

- Whitehouse, TX, USA

problem #102

Nov 142014

Edge 6-cyl

  • 101,637 miles
I was getting into the exit lane about 50 mph when my car comes to a sudden slow down of about 5 mph. Lucky I was already slowing down.could have been a bad situation had I not been exiting the freeway.

- Canyon Country, CA, USA

problem #101

Nov 112014

Edge 6-cyl

  • 83,731 miles
Driving around 45 mph in stop and go traffic, hit the brakes then the gas to no power at all I was barely moving in bumper to bumper traffic and when the traffic started moving again I was caught in the middle of 4 lanes of traffic barely at a crawl. I could have been killed just trying to get to the shoulder ! this problem is just as life threatening as the latest recall because of the bad key/starter issue. Are they going to wait to recall till we're killed driving our Ford Edge" am I the only one that has noticed all the complaints just this year involving the 2008 Ford Edge for this same issue" please recall.

- New Orleans, LA, USA

problem #100

Nov 012014


  • 62,000 miles
Kept loosing transmission fluid. Dealer told me power train at a price of 1400 + this is a fault of the Edge model with AWD.

- East Brunswick , NJ, USA

problem #99

Nov 042014

Edge 6-cyl

  • miles
I sent an email to the Ford company, we have a 2008 Ford Edge we bought new we have always had an issue with the transmission and the car not moving unless you stop and restart it, the issue was so sporadic from the 1st year that we have had in the dealership several times and they cant seem to find a problem, the car would have the air bag, wrench and low tire light on and the odometer would be all dashes, you could floor it and the tach will move but the speedometer would not move and the car would barely move, lately the issue has become an everyday thing yet still the dealership cant find the problem, I was checking online and found that many people are having the same issue with their Edge, many videos showing the exact problem, my Ford dealer is looking at it again. We can not be the only one having this issue.

- Caledonia, OH, USA

problem #98

Oct 262014


  • 86,600 miles
I have only had my Edge a month, had it checked bumper to bumper before purchase (I work at an auto shop) and read reviews online. I wish I had seen these complaints about the transmission and hard shifting/revving before purchase!! as soon as I bought it, within a few days when I would leave work and try to accelerate it hesitates, clunks loudly, then finally catches and takes off.. I've already had new plugs/boots/coils done, new belts and flushes done. Yesterday was the worst - I was taking off from a red light and as I was pressing the pedal it revved and jerked and banged. So glad I haven't even made my first payment yet and seeing these complaints, already know I'm going to be sinking massive money into this vehicle! please recall Ford!!! I've driven crappy cars my entire life, I finally get something that looks nice I see is just another money pit lemon!

- South Bend, IN, USA

problem #97

Oct 222014


  • miles
Drove the car to work without any issue. After work, I drove to a nearby convenience store by my house and had no issue. I left the store and stopped at a red light. When the light turned green, I stepped on the gas pedal but the car barely moved and was laboring. I checked to make sure I wasn't on the L gear but it wasn't because I was on D. I kept pressing on the gas and noticed a wrench light on in the dashboard. I made it home at less than 10 miles per hour which was the fastest that the car would go.

- El Paso, TX, USA

problem #96

Sep 242014

Edge 6-cyl

  • 127,000 miles
I pulled out of my driveway and everything was fine. I pulled out of my neighborhood and as soon as I gave it any good amount of gas it starting driving really rough and shaking and the A/C went out you could hear the misfire on the cylinders and the transmission was revving high before it would shift gears. No check engine lights or anything at this point. I turned back around and took my car back home turned it off and then turned it back on and that's when the check engine light came on. We pulled the code and it was P0352 (ignition coil 2 or PCM) so we bought and changed all spark plugs and coil 2. this still didn't fix the problem. So I took it in to the dealership and $3000 later they had to replace my PCM (the main computer that run the car) all 6 coils and spark plugs. I did a lot of research about my car having this problem and it seems like a lot of people are having the same issue. Please recall this. My computer should not have gone out when I do regular maintenance on my car.

- Arlington, TX, USA

Read the next 20 complaints »

Not what you are looking for?