Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
12,358 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2001 Nissan Altima engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Nissan Altima:

Unsubscribe any time. We don't sell/share your email.

2001 Nissan Altima Owner Comments

problem #8

Dec 082003


  • Automatic transmission
  • 32,060 miles


While driving, the vehicle stopped in heavy traffic with the engine still running and without any warning, the vehicle suddenly accelerated. Consumer engaged from drive to neutral.

- Staten Island, NY, USA

problem #7

Aug 222003

Altima 4-cyl

  • Automatic transmission
  • 34,000 miles
I have a 2001 Nissan Altima. At aprox 34,000 miles (car now has 42000) the instrument cluster would fail, the overdirve light would start flahing then overdrive would disengage. The instrument cluster and overdrive would come back on then minutes later the engine would start lurching causing the car to slow to 30 mph and eventually stop. The engine would still run but revving is choppy and lagged. After a few minutes or shutting the engine down and reststarting the engine the car would return to normal, but after a period of 10 minutes would repeat incident. Have taken to a dealer on 4 occasions, but mechanics cannot duplicate failure. Only one code has come back from the diagnostic P0500 (speed sensor failure) and the service engine light has only come on once. This issue has been re-occurring since April of 2003 and no repairs have been attempted due to the fact that mechanics cannot find nor duplicate problem. I have recorded 15 or more failures since April and 9 in the past 4 days.

- De Soto, IL, USA

problem #6

Aug 122003


  • Automatic transmission
  • 16,800 miles
The automobile accelerated while the consumer's foot was on the brake. The consumer took the vehicle to the dealer/mechanic three times and because the vehicle did not duplicate the problem, the mechanic was unable to find out what was happening with the automobile. The third time he just left the vehicle with mechanic/dealer so that they may drive the automobile to see if the problem resurfaced. The vehicle was shifted into drive but went into reverse.

- Portland, OR, USA

problem #5

Jul 172003


  • 16,000 miles


Consumer states that when vehicle is put in park engine races and jerks forward intremittently while foot is on the brakes.

- Portland, OR, USA

problem #4

Jan 032002


  • miles
On three occasions vehicle would suddenly accelerate and deaccelrate while driving between 30-60 mph. Vehicle at dealer shop. Feel free to provide any further information concerning this matter.

- Saint Louis, MO, USA

problem #3

Oct 262001

(reported on)


  • miles
While backing out of driveway a loud noise occurred followed by fumes from under the hood. Seconds later, vehicle suddenly accelerated to 80 mph and hit a brick wall, cause unknown.

- Austin, TX, USA

problem #2

Jun 012001


  • miles
On two occasions, in stop & go traffic, while stopped with my foot on brake, the engine started racing, when I took the car out of gear, the engine rpms "took off" I shut off the engine and restarted, everything was fine. When this first happend, I took the car back to the dealer but they could not find anything wrong. I thought it was a fluke the first time but now I think there is something seriously wrong. On both occasions, I was stopped with my foot on the brake, not on the accelerator, when the engine started racing, the only way to control it was to shut off the engine. I am taking the car back to the dealer, hopefully they can find the problem.

- Marietta, GA, USA

problem #1

Oct 052000


  • miles
Vehicle would accelerate & go into overdrive on its own. Was driving 5mph down alley way. Put into neutral & engine started roaring, and rpms went racing high. Vehicle towed to dealer.

- Woodsboro, MD, USA

Not what you are looking for?