If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

CarComplaints.com Notes: The 2012 Ford Escape has an acceptable complaint history so far, with leaking rear window problems showing up as the main concern so far. NHTSA complaint data shows an early pattern of problems with stalling while driving.

Another concern is the 2012 Escape rolled onto its roof during an NHTSA side impact test so it only received a marginal side impact rating ... not good.

4.3

definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
26,053 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2012 Ford Escape engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2012 Ford Escape:

Unsubscribe any time. We don't sell/share your email.

2012 Ford Escape Owner Comments (Page 1 of 2)

problem #33

Jun 042014

Escape

  • 80,000 miles

A D V E R T I S E M E N T S

Car makes a jump when accelerating was told there is a extended coverage on the throttle body and that its possibly the throttle body causing the jult, but Ford will not fix under the extended coverage recall until the engine light comes on.

- Norfolk, NE, USA

problem #32

Oct 202014

Escape

  • 83,000 miles
My car decelerated rapidly and was unresponsive when applying the gas pedal. Fortunately I was able to make it to the side of a busy interstate without incident. The car behaved as if it were going to shut down. The "wrench" indicator light was on, (check engine light). I turned off the car, and when I turned it back on the light was no longer illuminated, and the car was responding to the gas pedal. I still felt that the car was "dragging". I think it is a throttle body issue.

- Falling Waters, WV, USA

problem #31

Sep 242014

Escape

  • 51,000 miles
I was driving down the road at 40 mph and the engine began making rumbling noises and the engine began to shake as if were trying to shut off, I tried to give it some gas so it wouldn't stall but when I pressed the gas pedal nothing happened. Additionally, the car surges off and on while driving. When I contacted mike davidson Ford where I purchased the car, they acted as if they knew nothing about it and tried to schedule me for a diagnostic test at $89 to determine the problem. That's criminal, this car should be repaired quickly and at their expense! if this happens in heavy traffic or on the interstate it will be very dangerous.

- Jacksonville, FL, USA

problem #30

Dec 292011

Escape

  • 10,760 miles

A D V E R T I S E M E N T S

Loses power when accelerating from stop. And at times while you're driving. Have given the car gas to accelerate around a car only for the engine to bog down have taken the car in many many times to the dealership. Throttle body has been replaced twice. Problem still happening. Have gotten Ford involved but still receive no satisfaction. And did not fix the problem

- Belleville , IL, USA

problem #29

Jul 282014

Escape

  • 74,000 miles
Driving in the mountains of Kentucky, late morning. I was in the middle lane with the cruise control on, I saw that cars were breaking so I tapped on the brake to release the cruise. My car's ignition shut off

- Melbourne Beach, FL, USA

problem #28

May 212013

Escape

  • 18,678 miles
As per my vehicle report fromo the dealership: Concern 52*: tech notes clutch slave cylinder is leaking. Cause: Verify concern, find that vehicle has clutch fluid leaking from inside bell housing area. Correction: Remove trans & inspect, find that slave cyl is seeping fluid. Install new slave cyl & adapter. Assemble vehicle, no leaks found inside bell housing, but clutch live from master cyl to slave cyl will not seal properly. Install line, bleed system & retest, all pass. 52-3: manual transmission slave cylinder- hydraulic clutch - replace.

- North Charleston, SC, USA

problem #27

Jun 102014

Escape

  • 36,950 miles

A D V E R T I S E M E N T S

As per my vehicle report from the dealership: Concern 51: Customer states drive belt coming apart. Cause: Warranty correction: Verify belt shredded. Found water pump locked up unable to remove debris from tensioner replace water pump tensioner belt. Test drive ok.

- North Charleston, SC, USA

problem #26

Apr 292013

Escape

  • 18,678 miles
As per my vehicle report from the dealership: Concern 51: Verify cust concern, find that veh spins over but will not start, install ids & performed koeo, all pass. Perfom relative compression test, 80% loss 3,4. correction: Perform manual compression test. Cyl 1-180, 2-175, 3-0, 4-0. perform leakdown & pressure test, find that intake valves in 3 & 4 are not sealing. Remove valve cover & inspect camshafts, no damage found. Spin vehicle over & verify timing. Find that crank pulley has backet out & vehicle has jumped time. 51-1: remove intake, exhaust manifold, timeing components & cyl head. Inspect and finds that valves in 3,4 have contacted pistons, no damage found on pistons. Install new head gasket, cyl head bolts, 2 new diamond washers, all related gaskets & perform timing procedure. Assemble vehicle, change oil & fill fl. 52-2 koeo, pass. Roer vehicle has dtc PO524. Perform pinpoint test, replace vct solenoid, koer all pass. Test drive. Vehicle runs properly at this time. 51-5: cylinder head gasket- leakage (external leaks)- test

- North Charleston, SC, USA

problem #25

Feb 072013

Escape

  • 15,295 miles
As per my vehicle report from the dealership: Concern 51: C/S that battery light is on, please check and advise. Cause: Verified concern. Found belt thrown. Also found and oil leak at the front cover via a dime sized hole in the cover. Correction: Replaced front cover and vbelt. Also replaced motor mount that was stripped out. Verified repair. Battery light is off and no oil leaks at this time.

- North Charleston, SC, USA

problem #24

May 052013

Escape

  • 4,000 miles
When moving forward from a dead stop at an intersection of a busy highway, the automobile engine hesitates or semi stalls and will not pick up normal speed in order to get out of the way of approaching, on coming and following vehicles. At several different times we were almost rear-ended by vehicles behind us, or hit from the driver's side or front passengers side of the vehicle because of the engine's hesitation when crossing intersections or major highways. I took the vehicle to a Ford dealer and was told that "no problem" was found, but the problem still exists. I guess when a death or serious injury occurs something will be done!

- Glencoe, AL, USA

problem #23

Mar 202013

Escape

  • 17,500 miles

A D V E R T I S E M E N T S

Had to have engine mounts replaced due to vehicle heavily shaking. Also windshield was remounted at same time to due loud noise.

- Crescent Springs, KY, USA

problem #22

Mar 062014

Escape

  • 23,900 miles
Vehicle lost power on highway for approx 5-10 seconds, power came back slowly and then happened again a few minutes later for 5-10 seconds. Depressing accelerator had no effect.

- Beachwood, OH, USA

problem #21

Oct 302013

Escape 6-cyl

  • 54,000 miles
When pulling out from an intersection, I experienced intermittent power loss which resulted in vehicle loafing forward then stalling or entering safety mode low idle maneuverability with wrench light on. I was in heavy traffic and had to shut off the car, place in park then restart only to have the vehicle lurch then shut off or return to safety idle again before I was able to exit the street safely. After several attempts to restart, the check engine light came on resulting in trouble code P2111 "current" fault throttle actuator control system - stuck open and code P2112 " pending throttle actuator control system - stuck closed.

- Baton Rouge, LA, USA

problem #20

Sep 022013

Escape

  • 26,075 miles
The first time this happened I was driving home and turned onto a street as I accelerated the vehicle slowed down. I had my foot as low as the pedal would go and it would not move. I switched it to park turned it off and back on and it started up and was fine at accelerating. So the second time this happened about a month later I was driving about 30mph when my Escape slowed down and completely stalled out while I was driving on a very busy street. I pushed so far on the accelerator that the pedal was as low as it could go but still no movement. I quickly switched it into park turned off the vehicle and tried turning it back on but it just made the noise like it was trying to start. So I tried again and it finally turned on, switched to drive and was able to get off the street as a semi was flying up behind me. Very scary moment in my life. I googled about the issue and found that an investigation is going on regarding the throttle on 2012 Escapes. I think my vehicle may be a part of this.

- Berwyn, IL, USA

problem #19

Jun 122012

Escape

  • 41,000 miles
When driving the car would completely shut off, the check engine light would come on, and I lost control of steering and acceleration. I had to try to get over to the side of the road. The car would usually turn back on. I had to take it back into the Ford dealership 4 times for them to figure out what was wrong with it, as they thought they had fixed it each time.

- San Diego, CA, USA

problem #18

Jul 152013

Escape 6-cyl

  • 4,849 miles
Note, this has occurred at varying times/dates since purchase of the vehicle in 2012, has not just occurred at the date listed. When accelerating, the vehicle will have a prolonged hesitation and even a loss in speed when switching via the automatic transmission from 2nd to 3rd gear. This occurs every time the vehicle is driven, not randomly. Also, when getting up to highway speed, there is a hesitation if you touch the gas to accelerate up to the highway speed; it will hesitate a few seconds before kicking into acceleration mode.

- Dayton, OH, USA

problem #17

Jun 282013

Escape

  • 11,000 miles
At approximately 5:30 am while making a right hand turn up an incline the vehicle stalled - the oil and battery lights came on - I put it in park and turned the ignition off and then back on and restarted - I later took it to the dealership - they said they contacted the Ford technical hotline and are awaiting a response - this is the 3rd stalling incident the second at the same location and the 1st after they replaced the throttle body - the vehicle has around 11,000 miles.

- Vista, CA, USA

problem #16

May 012013

Escape

  • 56,000 miles
On the first occasion, I was pulling away from a stop sign and into traffic. My truck stalled in the middle of the intersection. I managed to shut it off, restarted and it was fi.e. I called the dealer ship and they told me a bug probably got in my air filter. About 3 weeks later it happened in the middle of the highway in traffic doing 75. I almost got smashed in the rearend. Managed to restart. Took it to the dealer ship and they said there was nothing wrong. I picked it up and drove it home, almost cause a 4 car pileup on the interstate. My guardian angel is worn out! finally got a code to pop up and the dealership told me it was the throttle body. No recall on this part even tho it seems to be a major issue.

- Boonville, IN, USA

problem #15

Jun 132013

Escape 6-cyl

  • 48,000 miles
Within the last week, I have experienced repeated incidents of stalling when in traffic and trying to accelerate from a stop. There were no warning signs prior to the initial failure or prior to subsequent failures. I am afraid that if this continues it could end up in a wreck with someone getting injured.

- New Orleans, LA, USA

problem #14

Jun 062013

Escape

  • 21,600 miles
The contact owns a 2012 Ford Escape. The contact stated that while traveling approximately 20 mph, the passenger's side engine mount bolt sheared off and caused the to engine to become detached from the vehicle. The vehicle was towed to the dealer where it was confirmed that the mount bolt had failed. The vehicle was not repaired. The manufacturer was contacted about the failure. The failure mileage was 21,600.

- New Orleans, LA, USA

Read the next 13 complaints »

Not what you are looking for?