Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


pretty bad
Typical Repair Cost:
No data
Average Mileage:
190,474 miles
Total Complaints:
4 complaints

Most Common Solutions:

  1. not sure (4 reports)
2000 Ford Expedition AC / heater problems

AC / heater problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2000 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2000 Ford Expedition Owner Comments

problem #4

Nov 302010

Expedition 4.6L

  • Automatic transmission
  • 167,895 miles


This was a good truck when we bought it about a year and a half ago, then the thermostat went out, had that replaced but still no heat, so I put another thermostat in it and still didn't fix heat, no smell of antifreeze so don't think its the heater core, just blows cold air! Not good in the winter time with 4 kids!

- , Monterey, TN, USA

problem #3

Sep 282008

Expedition XLT 4.6L

  • Automatic transmission
  • 185,000 miles

took a long time to get warm and worked fine until about a week later and it would not get hot, nothing but cold air . Replaced the heater core this summer because it was leaking, and did it myself saved $ 850.00. this time i changed the thermostat and flushed the rad. but only luke warm air seems like the water is not traveling like it should, so i think the head gasket is blown have to take it to the shop cause i am tired of fooling with iot

- , Pachuta, MS, USA

problem #2

Feb 012008

Expedition XLT 4.6L

  • Automatic transmission
  • 169,000 miles

The heat only works when its at a high idle or on the expressway. when idling the temperature gage drops and no heat comes out just cold air. The thermostat was changed radiator flushed. Can not figure out whats wrong. We have had nothing but problems with this truck....

- , Warren, MI, USA

problem #1

Feb 012007

(reported on)

Expedition Eddie Bauer 5.4 V8

  • Automatic transmission
  • 240,000 miles

I have a 2000 Ford Expedition Eddie Bauer I am getting no heat at all front or back cleaned out heater core changed water pump and thermostat had system flushed don't know what to do next

- , W. Hmpstead, NY, USA

Not what you are looking for?