Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

9.1

really awful
Typical Repair Cost:
$650.00
Average Mileage:
147,595 miles
Total Complaints:
13 complaints

Most Common Solutions:

  1. not sure (8 reports)
  2. there still no fix, dealer wasn't able to duplicate it (3 reports)
  3. fixed. it was the junction block (1 reports)
  4. replaced fuse box (1 reports)
2003 Ford Expedition engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2003 Ford Expedition Owner Comments

problem #13

Aug 092015

Expedition Limited 4.6L

  • Automatic transmission
  • 196,658 miles

A D V E R T I S E M E N T S

It shuts off about once a mile and restarts immediately, if you put the transmission in neutral and turn the key all the way off and back on. No loss in power before it shuts off or after it restarts. Nothing else shuts off other than the engine. The check engine light is on for O2 censor codes. It will idle in park for a long time but shuts off while driving at any speed whether the engine was just started or been running for hours.

- , Valparaiso, USA

problem #12

Dec 292014

Expedition V6

  • Automatic transmission
  • 243,000 miles

I put in a new motor 50K miles ago. About 1 year ago my expedition turned off while driving. The second time it did that, I took it in to the dealer. They couldn't find anything wrong with it. I searched on the internet, someone said it could be the air conditioning cable. Checked that out, mine was fine. I noticed it would turn off when it had less than 1/4 tank of gas. Kept it above 1/2 a tank and it shut off again on 12-11-14 with 3/4 tank of gas. I thought maybe it was the float, but I guess not. The positive cable was loose. Ford no longer makes the red cover with the three attachments. Took it to a boat shop, they crimped it and fixed the loose cable. It had been ok until today, 12-29-14. My daughter is driving back home, 300 miles and it has turned off on her 3 times. It starts right up. It is very scary for her, having to keep starting it up every time and not knowing when it will shut off.

Update from Jan 13, 2015: Drove 300 miles one way, kept the tank at 1/2 or more. No problems going or coming back home. The following day it wouldn't start. Had it towed and fixed. It happened to be the JUNCTION BLOCK. They checked the fuel pump and it was fine. The junction block cost $400 from the dealer plus labor. A little less than $1,000 and now it works. I still need to drive it with a low tank of gas and see what happens.

- , SALINAS, CA, USA

problem #11

Jan 252014

Expedition 4.6L

  • Automatic transmission
  • 122,000 miles

I had this car for about 2 years, 3 times the engine was cut off while running, i know the problem is when fuse box got wet, how can i fix that?i think is very dangerous, i know too many people has same problem, why dont recall this vehicles for fix this problem?

- , Garden Grove, CA, USA

problem #10

Nov 192011

Expedition Eddie Bauer 5.4L V8

  • Automatic transmission
  • 175,000 miles

A D V E R T I S E M E N T S

While driving on the freeway at 65 MPH our Expedition's engine just turned off. We were rushing our dog to the emergency vet the first time this happened. Unfortunately we lost our dog that day. Luckily my husband was with me I was driving he told me to put it in neutral and try to start it back up it did start. We thought it was just something strange that happened until it happened 2 more times while driving on the freeway. I'm now afraid to drive in the fast lane on the freeway just in case it goes out again and I have to try and pull over to restart the expedition. I THINK THIS IS HAPPENING A LOT MORE THAN IT IS BEING REPORTED FORD NEEDS TO DO SOMETHING ABOUT THIS BEFORE SOMEONE IS KILLED BECAUSE OF THIS. THIS MAY HAVE ALREADY CAUSED SERIOUS ACCIDENT'S.

- , Manteca, CA, USA

problem #9

May 022013

Expedition XLT 5.4L

  • Automatic transmission
  • 147,000 miles

for me it could have been worse. I have had so much problems with this car, every time I drive it im scared something else would go wrong, but for this problem it would stall out of no where. I took it to the mechanic he had no idea what was wrong with it. then my husband searched most common problems with this car and said it was the fuse box and we changed it for about 300.00 bucks and its been 3 months and it hasn't shut off..... Hope this helps...

- , Perris, CA, USA

problem #8

Sep 112012

Expedition Eddie Bauer

  • Automatic transmission
  • 250,000 miles

My 17-year-old son drives a 2003 Expedition. Three times since school started this year the car has died while my son was driving it--complete loss of power, battery light on. All three times he coasted clear of traffic and was able to restart the car within minutes. While he has been fortunate in that he has been in the residential area between our home and his school all three times, I am very afraid for him to drive this car long distances or on the freeway. We have not taken the car for repair because it has been nearly two months since the last incident. Very strange. Very scary.

- , Castle Rock, CO, USA

problem #7

Jul 232012

Expedition XLT 4.6L

  • Automatic transmission
  • 135,000 miles

A D V E R T I S E M E N T S

My family was going to a funeral viewing. We were driving on the hwy at the posted speed of 70 mph when the car lost all power. The battery light came on and I lost all power steering and power brakes. It was very scary!

There were no error codes or a warning at all. I turned off the key and it started right back up. We drove another 2 miles then the same thing happened again. No power, no warning and no error codes. It started up again n we made it home. The next day we took it in but tech can't find anything wrong and no error codes still showing. I am afraid to drive with kids in car. There doesn't seem to be any answers. Just a dangerous car.

- , Azle, TX, USA

problem #6

May 032011

Expedition

  • Automatic transmission
  • 80,000 miles

Stopped on a local back and forth to grocery store from home. Took it back to mechanic and a switch or fuse or something relating to the fuel pump was replaced. We are at our wits end about what to do!!!!!

- , Perry, GA, USA

problem #5

Jun 272011

Expedition

  • Automatic transmission
  • 80,240 miles

This has happened numerous times (at least 20, 3 today 6-27-2011) ; I will be driving and it will seem that my auto is not getting gas and then the battery light comes on and it just cuts off unless I get a chance to pull over and shut it off first. Sometimes it will crank right back up and other times it takes a few minutes but does crank up so far. It is now at the shop again. I have replaced the fuel filter, the fuel pump, and last time a switch or fuse or something was replaced that relates to the fuel pump. This could definitely cause a major accident in the right location. So far I have spent around $1,000.00 and it is still not fixed and seems to be getting worse. This problem first started happening almost a year ago.

- , Perry, GA, USA

problem #4

Feb 162011

Expedition XLT 4.6L

  • Automatic transmission
  • 104,000 miles

Truck keeps turning off, I change the Relay and its fine

- , Elizabeth, NJ, USA

problem #3

Aug 192010

Expedition Eddie Bauer

  • Automatic transmission
  • 127,843 miles

A D V E R T I S E M E N T S

Yesterday my car engine died while I was driving. There was no warning, strange sound, or anything. It just died. I was in the process of turning left, and when the engine died, the power steering went out. I was unable to turn the tires enough to complete the turn, so I ended up rolling to a stop at the curb, sticking out in the intersection. Luckily some good samaritans came and helped my push the car to a safe spot. After about 15 minutes, the car started again, and seems normal. Ironically, the engine shut down 6 months ago while we were driving on the freeway. We thought it was just a fluke, but now after yesterday, I am very concerned. I took the car to a mechanic today. Of course they can't find anything wrong. I feel like I'm playing Rusian Roulet with my car.

- , DIscovery Bay, CA, USA

problem #2

Aug 082010

Expedition Eddie Bauer 5.4L V8

  • Automatic transmission
  • 165,000 miles

I'VE SPENT $1,000.00 AND STILL HAVE THE PROBLEM. TWO SHOPS HAVE LOOKED AT IT. THE FUEL PUMP,GAS CAP AND CRANK SENSOR HAVE BEEN REPLACED AND IT STILL CUTS OFF WITHOUT WARNING. WE CAN NO LONGER TAKE OUR FAMILY IN THIS VEHICLE BECAUSE IT SEEMS TO LOVE CUTTING OFF IN HEAVY TRAFFIC OR IN BUSY INTERSECTIONS. I CAN'T FIND AN ANSWER ANYWHERE!!!!! THIS BEGAN IN MAY 2010 AND I STILL HAVE THIS ISSUE.

- , Peachtree City, GA, USA

problem #1

Jun 062010

Expedition 5.4L

  • Automatic transmission
  • 93,000 miles

THIS HAS HAPPENED THREE TIMES, TWICE ON THE FREEWAY AND THE MOST RECENT IN MY HOUSING AREA!!

- , Chula Vista, CA, USA

Not what you are looking for?