Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

7.3

pretty bad
Typical Repair Cost:
No data
Average Mileage:
121,917 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (2 reports)
  2. tune up, replace spark plugs (1 reports)
2000 Ford Expedition engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2000 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2000 Ford Expedition Owner Comments

problem #3

May 182015

Expedition Eddie Bauer 5.4L V8

  • Automatic transmission
  • 250,000 miles

A D V E R T I S E M E N T S

Worst gas mileage, #1 #4 misfire, then when taken to mechanic they tell me for the tune up is 350 but if he runs into the problem that most of these engines have can be up to 150 for each plug if it breaks or strips. I HAVE 8 PLUGS DO U KNOW HOW WORRIED I WAS ... lucky for me he knew what he was doing and there was no issue but I will have to file another complaint because one did on a previous issue with a different mechanic

- , Morrow, GA, USA

problem #2

Nov 062007

(reported on)

Expedition XLT 5.4L V8

  • Automatic transmission
  • 77,750 miles

well, i wrote on here a few months ago about my truck sputtering when i gave it gas...auto zone told me cylinder #5 was misfiring and i needed a new coil pack...i took it to a local car dealer where i knew someone who worked there and had him take a look at it...he said it wasn't a coil pack, so i had him switch #1 and #5 just to see what happens...it did fine for about 3 hours, then it went back just like it had been doing...i drove it like that for about a month or so until my check engine light came back on...so i took it to a shop called tuffy...they did the diagnostics check on it and it said the same thing (not sure if they cleared the code from the first time or not)...they said i need a new coil pack on number five. so this time i said ok and went and bought a brand new coil pack, i took it back to them and let them put it on...guess what, still throwing code and didn't fix problem...so then i went and bought a new plug for #5 and replaced the old one...still nothing...checked all my injectors, they were fine...checked everything i knew to and still nothing...tuffy finally gave up and told me they had no idea what was wrong with my truck...it is still doing it...i have no idea myself but i do know it is hurting my gas and sounds like crap whenever i give it gas...if anyone has any ideas what it could be or any suggestions on how to fix it, i would greatly appreciate it...you can email me directly at shaunmcfd@comcast.net...thank you

- , Dothan, AL, USA

problem #1

Sep 042003

(reported on)

Expedition

  • 38,000 miles

This miss was a sudden onst. After warm-up it has a very disturbing misfire (stumble) under part throttle. Increase throttle and it clears up. It was put on a diagostic read out through the OBC access and no problem shows up.

- , Reno, NV, USA

Not what you are looking for?