Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


pretty bad
Typical Repair Cost:
Average Mileage:
53,000 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (3 reports)
2003 Ford Expedition AC / heater problems

AC / heater problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2003 Ford Expedition Owner Comments

problem #3

Nov 032007


  • Automatic transmission
  • 69,000 miles


I brought it to the dealers several times before they finally found the problem it would have costs over 1000 dollars but I bought the part for $90 and paid someone $200 to do it this is an ongoing problem with my heater and ac.... so sick of it

- , Manchester, CT, USA

problem #2

Aug 012008

Expedition Eddie Bauer

  • Automatic transmission
  • 60,000 miles

Have the exact same problem as described in the previous post. AC works fine around town (live in Vegas) but as soon as we go on long freeway trips it loses power and barely puts out cool air. As soon as we turn it off for 10 minutes (not pleasant driving through the desert) or turn the car off everything works fine for a while. We have taken it to two mechanics and neither could find a problem.

- , Las Vegas, NV, USA

problem #1

Nov 142006

(reported on)

Expedition XLT 4.6L V8

  • Automatic transmission
  • 30,000 miles

This problem will happen in the hottest months of the summer (SW US), and on long highway trips (1 hour or more).

Usually it goes like this: 1. We board our expedition for a long trip on a hot summer day. 2. Since we live in Tucson (can get pretty hot), we immediately turn the AC on, coldest setting, highest fan setting. 3. After about 30 minutes, when it's nice and cool, we lower the fan speed to the 1 or 2 setting. 4. After about 40 minutes of riding, we begin to feel a little warm, so we raise the fan to the next level. We then realize the fan is not blowing as hard as it should, even at the highest level. 5. At this point, the highest level of the fan will blow just like the lowest level. 6. It seems like the air conduit somewhere has been frozen or something. 7. Solution is to turn the AC off for about 10 minutes, or stop the car for about 5 minutes. 8.. A large puddle of water will be on the ground, and we're good to go.

Two different Ford dealerships have looked at it. One replaced the wrong part (didn't fix the problem). The other couldn't duplicate the problem (in the 3 minute drive they take around the block -- idiots!), so "No problem was found".

- , Tucson, AZ, USA

Not what you are looking for?