Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

10.0

really awful
Crashes / Fires:
2 / 0
Injuries / Deaths:
3 / 0
Average Mileage:
55,600 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2010 Ford Escape electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2010 Ford Escape:

Unsubscribe any time. We don't sell/share your email.

2010 Ford Escape Owner Comments (Page 4 of 8)

« Read the previous 20 complaints

problem #94

Sep 082013

Escape

  • 43,000 miles

A D V E R T I S E M E N T S

Car throttle almost stalls to rough idle, sputters but cannot give it gas or rev engine wrench symbol lights up you must turn off car to restart after about 10 times and it happening every mile or so the check engine light is on and stays on even after restarting. This will happen out of nowhere while driving at any speed but idles just enough to pull over to safety ! restart and drive a mike and either just idling or accelerating it just quits going. I called taylor Ford and was told I was out of warranty but need throttle body and approx $450 ! so they too know it's an issue!

- Taylor, MI, USA

problem #93

Sep 072013

Escape

  • 90,000 miles
I was driving at 20 miles an hour when suddenly the tool light came on and my Ford no longer would get gas from the gas pedal. I was suddenly coasting without ability to give gas to the car however the engine was still running. It came to a stop after I was able to get out of high traffic area almost getting hit by other cars. There is no warning it happened suddenly. Shut off car turned back on and was fine. On the 9th of Sept just a couple days later this continued to happen a total of three times almost causing a severe accident--something needs to be done about this as it has been reported too many times as being a electronic throttle body failure and it is a defect. I am having to pay for the repairs at the Ford dealer tomorrow as I had it tested today and hooked up to diagnostics and there was nothing that gave warnings. I was told to take to the dealer it must be electrical problem. Also the RPM's were going crazy when this happened each time. The Agency needs to have it so it is recalled item so this wouldn't be coming directly out of the consumers pocket--it is obviously a defect in the Ford 2010 Escape--I want a refund!!!

- Blair, NE, USA

problem #92

Sep 032013

Escape

  • 45,895 miles
My daughter was driving to school on the hwy to school and car shut down completely which lost all power pulled over and tried to restart and had to wait places to me (father) and then it restarted then she drove on to school then she took car on to dealership and dealership performed search and found that it was a throttle body that was going out.

- Midland, TX, USA

problem #91

Sep 042013

Escape

  • 53,000 miles

A D V E R T I S E M E N T S

Throttle body failure: Replacement not only costly, but also on back order and is estimated to take several weeks.

- San Diego, CA, USA

problem #90

Aug 262013

Escape 4-cyl

  • 3,600 miles
I was driving about 60 mph when the car lost all power, let cool for about 20 minutes. Then drove it about 20 miles it died again. Let it cool again an it did this 4 times before getting to dealer. The same thing happen on Aug 9 2013 but would not start. Dealer examined starter and found nothing wrong by checking codes. This has happened today a total of three times in one year two of those times I was in heavy traffic and was lucky I was not hit from behind. Ford needs to check and recall these cars, but they need to see body counts before they see a need to do something.

- Canyon Lake, TX, USA

problem #89

Sep 022013

Escape 6-cyl

  • 652,013 miles
Repeated instances of the vehicles either stalling in motion or suddenly surging forward when accelerating from a stop. *

- San Antonio, TX, USA

problem #88

Sep 012013

Escape

  • 65,235 miles

A D V E R T I S E M E N T S

The vehicle needs a new electronic throttle body error code P2111. The car will lose power, the wrench light will come on, then the engine light will follow. Once the car is powered off, then back on it runs again. A few minutes later the same issue occurs.

- Alpharetta, GA, USA

problem #87

Aug 312013

Escape 4WD 6-cyl

  • 48,070 miles
Driving in the middle lane of a highway going 70 mph, car bucked, wrench light came on, and dropped speed rapidly. Pulled over, car was idling rough, tried to hit the gas and the car just jumped forward slightly 3 times going less than 3 mph. Turned the car off, back on, and didn't want to start but finally did, wrench light went away and the car drove fine. Drove it to the Ford dealership 1.5 miles away and they stated it was the electronic throttle body that failed and needed to be replaced.

- Chelmsford, MA, USA

problem #86

Aug 282013

Escape 6-cyl

  • 70,002 miles
Ford Escape has no power. Idles at less than 1000 rpms occassionally sputters.

- Grove City, OH, USA

problem #85

Aug 262013

Escape

  • 30,000 miles
Whe leaving our home in haines city, fl. The vehicle roughly changed gears. Then we entered a very busy highway and went to accelerate and lost power, and acted like it wanted to stall the drive triain light then lit up.the vehicles behind blew their horns because the vehicle slowed substantialy without showing brake lights.we took the vehicle to the Ford garage, and charged us for analizing the problem and the cost and installation of the throttlebody. The service representative told us he fthought it would be the throttle body, prior to analizing it.after researching Ford vehicle problems on the computer, I found that this is a common problem with the Ford vehicles.this is a problem that could cause very serious rea end collisions, and should be the responsibility of the Ford motor to repair and to resolve the problem.thisshould not be a failur of this part on a vehicle with low mileage especially.

- Haines City, FL, USA

problem #84

Aug 232013

Escape 4-cyl

  • 50,211 miles

A D V E R T I S E M E N T S

Driving 70 mph on hwy truck just starts to stall no control of gas pedal cars almost crashed in to me I was lucky I was able to coast out of the way. Trouble code is P2111 needs a new throttle body that is on back order for a Ford national recall and I have to wait days to get, price for part is $380. After a call to Ford customer service they said my car is not recalled but funny how the part number changed and it is the same one they have a recall on and they will not replace the part since my car is out of the 3 years 36,000 mile warranty my truck has 50,000 mile. Ford has lost a long time customer !!! buy american made !!!! thanks Ford ex owner of Expedition, Explorer, thunderbird, Cougar, town car, 2 continentals no more Ford at my house.....!!!!!!!

- San Antonio, TX, USA

problem #83

Aug 152013

Escape 4-cyl

  • 73,568 miles
I was driving on highway 680 in stop N go traffic. I put my foot on gas to go, but my car just wouldn't go. I tried to accelerate, but nothing happened. I quickly pulled over in the shoulder on the right side. The car started shaking. I put my car in parking mode and turned off the engine. I restarted it again, and it worked. So, I went into the oncoming traffic to get back on the highway. After about a mile further in stop N go traffic, my car did the same exact thing. It stopped working, and started shaking when I pulled over to the shoulder. I turned off the engine again. I wasn't feeling comfortable with driving my car since same thing happened twice. So, I had to call the tow company and had it towed to my home.

- San Jose, CA, USA

problem #82

Aug 232013

Escape 6-cyl

  • 30,300 miles
Was driving on the expressway at 70-75 mph. Suddenly lost power and car started to vibrate. Was able to pull over without incident but could have been a bad accident as I was in the passing lane. Once I pulled over I notice the wrench light was on which indicates a powertrain problem. The dealer states that it's the electronic throttle body. This vehicle had a similar problem about a year ago. The throttle control module had to be replaced. Fortunately at that time the car was still under warranty. With this incident the car is over warranty by 300 miles.

- Royal Oak, MI, USA

problem #81

Aug 222013

Escape

  • 30,800 miles
This is the second time this has happened. I came to a stop. The car shuts off completely on its own and was unable to start it up for a period of time in either park or drive. This also happened at approx. 7000 miles. Each time I take it to the shop, they are unable to replicate or find any errors within the system, so they refuse to correct or try further diagnostics to replicate the issue.

- Santa Clara, CA, USA

problem #80

Jul 152013

Escape 6-cyl

  • 53,415 miles
Driving at 60mph motor shut off no lights no sound, no warning.

- Edwards , MO, USA

problem #79

Aug 142013

Escape 4-cyl

  • 7,700 miles
I was driving down the freeway when suddenly, my engine lost power. A wrench light came on, and my throttle was completely unresponsive. Fortunately, I was in the right lane, so I was able to coast safely off the freeway and onto the side of the road. I shut my car off, waited a minute or two, and then restarted my car. Everything seemed fine after that. This happened again, now totaling 6 times, all while I was driving. Went to the mechanic, he called the dealership. He was told that this was a very common problem and that he could put a rush order on it for an additional 15% of the price, and it would still take 2 weeks. Through normal channels, it would wake several months. I need my car to work, and two things bother me the most: A rush order would still take 2 weeks to be delivered, and if it's a common problem, it feels as though Ford is doing nothing to alleviate it, especially since it impairs my ability to drive safely on the road. I am constantly paranoid while driving on the road, and I have no other choice but to continue to drive my car, since it's my only means of transportation.

- Los Angeles, CA, USA

problem #78

Aug 182013

Escape 6-cyl

  • 80,000 miles
Vehicle stalled upon acceleration from stop, and lost all throttle function. Surges at idle, and intermittently stalls. Throttle failed the next day at highway speed. Same symptoms as the failed throttle body sensor issue that was fixed by October 2009, but my Escape was built in December '09 after the problem was supposedly fixed.

- Boston, MA, USA

problem #77

Aug 172013

Escape 4-cyl

  • 98,000 miles
The vehicle is a 2010 Ford Escape. Driving my 2010 Escape the engine stalled. The speed I was going was about 20 mph. With no prior warning the wrench light came on, the RPM's fluctuated and I could not accelerate the vehicle. The dealer said it could be a number of things but after investor I found in the internet very similar behavior with other Ford Escapes and it said that at the end it was the electronic throttle body needed to be replaced I waited after 3 days with my car at the dealership and called them and told them to check the throttle body. They confirm that it needed to be replace, but I told them and yet I had to pay for diagnostics and the replacement of the throttle at my expense as it was not under warranty. This engine stall issue occurred 08/17/2013 to 08/19/2013 ( 5 times).

- Miami, FL, USA

problem #76

Aug 092013

Escape 6-cyl

  • 41,000 miles
When coming to a stop and then trying to accelerate from and idle position the vehicle will loose power. By this I mean the vehicle stays on, lights on dash remain on, motor is still running, but the accelerator pedal has no effect on the vehicle. The vehicle has shutter to it. Pressing the gas pedal has no effect no matter how much you try or how much time passes. You have to coast to the side of the road, turn off the vehicle, and restart the vehicle to get the gas pedal working again. This is a very very dangerous flaw in the vehicle as this has happened to me three times in busy los angeles intersections. I fear it will cause an accident. The Ford dealer wants to charge me $800 to replace the throttle body which has hundreds of thousands of complaints online about this exact issue. They refused to acknowledge this recurring and very prominent flaw in their vehicle and say even the extended warranty I purchased for $2,200 will not cover this particular part. This is very frustrating. Hopefully you guys can bring some justice to the hundreds of thousands of people dealing with this exact issue. Thank you for your time.

- Los Angeles, CA, USA

problem #75

Aug 152013

Escape 6-cyl

  • 51,230 miles
Was driving family back to out cabin in pigeon fodge tn, all of sudden in three lanes of traffic our SUV made a sudden surge and lost forward motion speed dropped and it would not go above 1 grand on tachometer. It would crawl but barley. Traffic behind me started blowing their horns. I hit the emergency lights. And started to getus off the parkway. We made it. The yellow wrench appeared on the dash and the SUV idled very ruff. I turned it off. Waited looked under the dash. Got the family out because it was hot outside. Then did not learn anything from hood up. Started the SUV back up and it ran. Got the family back in the SUV and went back to cabin. Thanks that is all I know. We have to go back home in morning so I hope I can make it 3 hour trip.

- Holden, WV, USA

Read the next 20 complaints »

Not what you are looking for?